How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka- Moose) Your Own Question
Chris (aka- Moose)
Chris (aka- Moose), Technician
Category: Transmissions
Satisfied Customers: 47289
Experience:  16 yrs. experience with auto, manual, & CVT drivelines
2499435
Type Your Transmissions Question Here...
Chris (aka- Moose) is online now
A new question is answered every 9 seconds

Chevrolet 2007: I have a 2007 Chevy dura max diesel 2500 and

Customer Question

I have a 2007 Chevy dura max diesel 2500 and it keeps going to shift invitation mode. I have replaced the ignition switch and key switch. Now they it low voltage and a wire a is broke going to the TCB. What are your thoughts?
Submitted: 2 years ago.
Category: Transmissions
Expert:  Chris (aka- Moose) replied 2 years ago.
Hello, I'm Chris. Thanks for seeking us for help.
Any trouble codes stored?
What symptoms are noticed while driving outside of warnings?
Can you go into better detail on this "Now they it low voltage and a wire a is broke going to the TCB?"
You want a excellent 5 star answer & I would like to be rated the same for providing it. Consider I don't know your skill level & I can't see, smell, hear, or touch the vehicle. It may take a few back and forth replies. Try your best to respond with good detail so I can do the same. I normally log in at 3pm and work late. A rating is required. Your rating me, what I type. I am not an employee of this website, nor have control over the fees or the time it took to get a response. If you rate negative or not at all you still paid, but I get nothing. I want you pleased with me and my efforts, so let me know if your experience here has come up short.
Thanks Chris
Expert:  Chris (aka- Moose) replied 2 years ago.
With the given information all I can come with is a generic answer that is possibly wiring damage to blame here.

Related Transmissions Questions