How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ted Ritter Your Own Question
Ted Ritter
Ted Ritter, Toyota Master Tech
Category: Toyota
Satisfied Customers: 4254
Experience:  Toyota Master Tech, ASE Certified
1279120
Type Your Toyota Question Here...
Ted Ritter is online now
A new question is answered every 9 seconds

Engine starts runs-idles good. at about half throttle with

This answer was rated:

engine starts runs-idles good. at about half throttle with no load injector ground wire changes to varying voltage. cam-crank sensors good and new.
JA: Does the vehicle stall at low speeds? Does it sputter?
Customer: no. falls flat-bogs down at about half throttle
JA: What is the model/year of your Toyota?
Customer: 00 camry 4cyl
JA: Are you fixing your Camry yourself? What have you tried so far?
Customer: we are a shop.its a cust car..had blown head gasket. veh drove ok into shop. timing belt marks ok. cam marks dead on. inspected crank reluctor wheel. cam sensor nub on cam
JA: Anything else you want the mechanic to know before I connect you?
Customer: installed used ecu this morning

Hello, thanks for posting

It sounds like the computer is turning the injectors off, can you check live data and see what happens to injector duration when this happens? There should be no voltage measured at any of the injector grounds, there could be a ground problem somewhere else which causes a feed back voltage, where are you getting this injector ground voltage and how much is measured.? re check the other ground connections at the intake manifold.

Customer: replied 1 month ago.
when engine boggs down about 2800 rpm inj pulse with opens up. when we introduce a spray in the intake when the issue happens the rpm increases and engine runs fine. fuel pressure and volume are good. 55 psi and does not change during issue.
ecu replaced today with no change. its def a fuel issue but cant pinpoint a control issue or mechanical. all grounds have been rechecked and are good. ecu ground behind drivers headlight also good

What about the fuel pressure regulator, could it be bypassing too much fuel back into the tank? Something has to be happening to the fuel that the engine needs to get to higher rpm which you are substituting by spraying fuel into the intake

Customer: replied 1 month ago.
fuel pressure stays at 55 even when issue happens. regulator is mechanical on end of the rail so I can't make it go full pressure but I can see it move back and forth with change of rpm
maybe the injectors are mechanically bad when made to increase volume.. control side is working. its a strange issue
Customer: replied 1 month ago.
ill be back tomorrow. have to close up now

Ok, maybe pinch off the fuel return line and see what happens.

Customer: replied 1 month ago.
ted. the problem ended up being the fuel pressure vibration dampner shutting off fuel when demand was high. this part is on the end of the fuel rail. the pressure regulator is in the tank. thanks for youyr help

You're welcome, I've seen those leak before but not cause a loss of pressure, thanks for letting me know, good luck, please take a moment tp leave a rating.

Ted Ritter and 2 other Toyota Specialists are ready to help you