How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Auto Technician
Category: Toyota
Satisfied Customers: 868
Experience:  16 years of experience
2499435
Type Your Toyota Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

I have a 99 Toyota 4Runner. I put a new motor in it. I used

Customer Question

I have a 99 Toyota 4Runner. I put a new motor in it. I used the original wiring harness. The old motor was running fine but had a scored cylinder. The new motor starts but immediately and idles back up and process starts again or it cmpletelly dies. I have removed the tank and replaced the fuel pump, changed the MAF, switched out throttle bodies. I have looked for vacuum leaks. Any ideas?
JA: Have you ever replaced the fuel pump, or is this the original?
Customer: As I stated I put a new one in trouble shooting. When it idles it seems smooth but when I feather the throttle it misses and seems starved for fuel.
JA: Are you fixing your 4Runner yourself? What have you tried so far?
Customer: Yes. Can u see my long list of things I have done?
JA: Anything else you want the mechanic to know before I connect you?
Customer: No
Submitted: 2 months ago.
Category: Toyota
Expert:  Chad Farhat replied 2 months ago.

Hi, I'm Chad. Welcome to JustAnswer. I'm reviewing your question and I will be posting your reply ASAP.

Expert:  Chad Farhat replied 2 months ago.

Hey how are you

1- i will try to help you on it , i have read what you have done so far .

2- is there any security light blinking on dash ?

3- if we have Correct fuel & spark & the car should start and run good. so what are we missing ?

4- does it start every time ,just you can not treve it up ,it will die correct ?

5- do you have any fuel trim readings at idle ,long term & short term ?

6- also , on a scanner ,fuel status : open loop or closed loop at idle ?

7- u change fuel pump ,what is pressure now key on ? these are your specs on it :

Fuel System Pressure

Idle Pressure - No Vacuum38 to 44 PSI psi

Idle Pressure - With Vacuum33-38 PSI

5 Minutes After Ignition Off21 PSI or More

8- inspect TPS sensor electrical connector for any backed out pins or broken pins making poor or intermittent connection ,use a flash light to shine in connector

9- on cold engine ,spray starting fluid around intake while running at idle ,does engine rpm surges up ?if it does u have vaum leak

10- ON SCANNER PULL UP TPS SENSOR AND REV UP , DOES THE VOLTAGE MOVE FROM 1 V TO 5 OR STATS STILL?

LETS START HERE & WE GO FROM THERE

Please let me know

Thank You

Chad Farhat

ASE Certified Technician

Expert:  Chad Farhat replied 2 months ago.

click on link to view wiring circuit diagram,u can see the injectors , the ECM controls the pulsing , are they still pulsing when open throttle

Customer: replied 2 months ago.
To answer your questions starting at the top number one. No there is no security light flashing. It starts every time and idols for a second or two and then dies or barely stays idling at about 2 to 300 RPM and with her catch itself and rev right back up and die again or it will die is it possible that I'm not getting voltage to the fuel pump after the search cycle I do not have a scanner today but will try to get one tonight I will then try to look at the fuel trim I am working on getting an adapter to read feel pressure at the rail.
Expert:  Chad Farhat replied 2 months ago.

ok sounds good let me know

yes I need more info

1- what is possible is a vacuum leak around intake or TB body or vacuum lines ,get some starting fluid when you get the scanner and spray starting fluid around the intake / tb body and let see if the engine rpm surges up

2- i believe you are getting voltage to fuel pump since we running but more likley not getting enough fuel,it important we check fuel pressure

3- But let start here and we go from there

I m online daily from 7 am till late ,this will take some back forth between us,if that dont work then i sent you wiring diagram so we follow electrcial issue but first ,scan, fuel prsseur & vacum leaks, fuel trim will be big help at idle ,long termand short term also read tps sensor voltage i lke to know these and the fuel status are we running open loop or closed loop ?

please read below how easily you can get back in touch with me

you can always come back to this conversation and ask me any follow up question you may have on this issue

(you can copy this link page & paste it in your browser when ready and it will open up our conversation again)

Thank You
Chad Farhat
ASE Certified Technician

Related Toyota Questions