How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Peter Bagley Your Own Question
Peter Bagley
Peter Bagley, Auto Service Technician
Category: Toyota
Satisfied Customers: 512
Experience:  master tech at Toyota dealer
24571351
Type Your Toyota Question Here...
Peter Bagley is online now
A new question is answered every 9 seconds

Power steering issue. works fine then doesn't. figured out

Customer Question

Power steering issue. works fine then doesn't. figured out that when its not working there no vacumm. shut it off and start it and its fine but stops working if I start driving it. shut it off and start it back up and it'll work sitting there
JA: When was the fluid last checked? Have you heard any whining noises while turning the wheel?
Customer: full on fluid. belt is fine. yes it whines when it's not working
JA: What is the model/year of your Toyota?
Customer: 97 tacoma
JA: Are you fixing your Tacoma yourself? What have you tried so far?
Customer: yes. not too much
JA: Anything else you want the mechanic to know before I connect you?
Customer: my first message contained the detail
Submitted: 4 months ago.
Category: Toyota
Expert:  Peter Bagley replied 4 months ago.

Hello and welcome to just answer. I value your input to my questions so I may help you better. Ok let me get this picture right. If you sit still while running it works fine? It looses the assist when moving?

Customer: replied 4 months ago.
Seems accurate. Basically when there's a vacuum from the top hose at rear of pump it sound hood at works properly. If its not working and i pull that lone there's no vacuum. Could pump be bad?
Expert:  Peter Bagley replied 4 months ago.

Does this look like your pump? with two vacuum points to it?

Expert:  Peter Bagley replied 4 months ago.

this your pump

Customer: replied 4 months ago.
Vacumm point looks the same as whats on my pump but not sure thats my tacamo pump exactly
Expert:  Peter Bagley replied 4 months ago.

Here is the vacuum layout where those hoses to the pump should be attached check to make sure they are attached properly

Expert:  Peter Bagley replied 4 months ago.

the valve your looking for is at the bottom of the picture. What this is supposed to do is limit assist at higher mileage to give you more road feel, but the manifold vacumm will go down then there will be some venture vacuum. put a vacuum gauge on each port and see if that changes and supplies what it should at each port , if they do then that valve on the pump is defective.