How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Auto Technician
Category: Toyota
Satisfied Customers: 814
Experience:  16 years of experience
2499435
Type Your Toyota Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

This morning, my 2008 Toyota Highlander wouldn't start. We

Customer Question

This morning, my 2008 Toyota Highlander wouldn't start. We jumpstarted it and now the indoor lights are flickering but the start button is not clicking, the engine won't start
JA: Have you double-checked the battery? And are the wiring connections to and from the starter in good shape?
Customer: I had the battery checked yesterday when I changed the oil and they said that the battery was good. How do I check the wiring connections to/ from the starter?
JA: Are you fixing your Highlander yourself? What have you tried so far?
Customer: We have tried jumpstarting it. Before we tried the jumpstarting there were no lights, no nothing turning on. After the jumper cables were connected from another car to our Toyota were connected, thinking it was the battery, that was when we pressed the starter button and saw the indoor lights coming on. However, the engine would not start.
JA: Anything else you want the mechanic to know before I connect you?
Customer: The lights are now flickering. We drove last night about 300 miles to get to Vermont.
Submitted: 15 days ago.
Category: Toyota
Expert:  Skyvisions replied 15 days ago.

At any time was the vehicle jumped backwards? Just to clarify you are saying that you have the jumper cables on the battery and on the car that is running and you still cannot get it to start up? Did you make sure you have good connections on the battery? Do you have good quality jumper cables?

Customer: replied 15 days ago.
I think so. We have some power but when we click on the starter button nothing happens
Customer: replied 15 days ago.
The engine doesn't start. Lights are on. The alternator is not doing anything
Customer: replied 15 days ago.
Hello? Still there?
Expert:  Skyvisions replied 15 days ago.

When you push your foot on the brake pedal with the jumper cables on the battery does the light in the start button turn green or does it remain orange? Is this a Hybrid?

Related Toyota Questions