How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Auto Technician
Category: Toyota
Satisfied Customers: 814
Experience:  16 years of experience
2499435
Type Your Toyota Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

2006 4Runner V8, CEL light on, VSC lights on. Original codes

Customer Question

2006 4Runner V8, CEL light on, VSC lights on. Original codes p1442 p1445 (I think), air pump replaced. Lights back on, vehicle is back in the shop for diagnosis
JA: Does the light stay on, or does it blink?
Customer: Stays on when it is on, but somewhat intermittent. First happened last February, I researched online, replaced the gas cap, stayed off until May, off and on periodically since then. It drives fine, no loss of power, no strange noises.
JA: Are you fixing your 4Runner yourself? What have you tried so far?
Customer: Other than the "gas cap try", no. A shop replaced the air pump for this problem, codes P1442, P1445. Lights stayed off for one week, now back in the shop for diagnosis
JA: Anything else you want the mechanic to know before I connect you?
Customer: No, I think that is all of the relevant info
Submitted: 24 days ago.
Category: Toyota
Expert:  Skyvisions replied 24 days ago.

Specific parts did you replace? Were they Toyota parts? Do you have part numbers? Did you replace the diverter valves or just the air pumps themselves?

Customer: replied 24 days ago.
The paperwork is in the vehicle at the shop right now. The air pump was replaced for certain, along with some gaskets and such. After the repair, the CEL + VSC lights were off for four days, then went back on. I took the 4Runner back in, they said that code P1442 appeared again, I think that they then swapped the solenoids to their opposite side, checking for loose connections and such. They kept the 4Runner last week after that attempt, but no lights. I picked it up last Thursday, no lights until this morning. As an aside, the vehicle pass the Colorado emissions test yesterday, but the lights went back on this morning. Thanks
Expert:  Skyvisions replied 24 days ago.

Did a Toyota dealer do the work?

Customer: replied 24 days ago.
No, an independent shop did the work.
Customer: replied 24 days ago.
the parts were Toyota parts.
Expert:  Skyvisions replied 24 days ago.

Can you get a copy of the invoice for the part number so I can see exactly what was replaced?

Customer: replied 24 days ago.
I'll try to track it down, thanks.
Expert:  Skyvisions replied 24 days ago.

OK let me know then I can give a better Idea as to what is going on.

Related Toyota Questions