How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Toyota Service Your Own Question
Toyota Service
Toyota Service, Toyota Expert
Category: Toyota
Satisfied Customers: 4608
Experience:  30+ Yrs of auto experience, Award Winning Svc. Manager; Just Answer Customer's Choice Award Winner
14892859
Type Your Toyota Question Here...
Toyota Service is online now
A new question is answered every 9 seconds

Have a 93 T100 Base truck with 3VZE engine - it sputters and

Customer Question

have a 93 T100 Base truck with 3VZE engine - it sputters and lacks power.
local toyota dealer just installed a brand new short block in it along with reman. heads etc.
Many new parts were installed: Timing belt & tensioner, water pump, knock sensor, bypass line and hoses, radiator, injectors, spark plug wires (denso) etc.
However, the truck runs like crap. Idles relatively OK but shakes badly as soon as i start to drive.
I am tired of back and forth with the dealer -- hoping to find an answers here.
I have checked and doubled checked spark plug wires, cleaned Throtlebody, replaced TPS and adjusted it.
Very little improvement,
Submitted: 1 month ago.
Category: Toyota
Customer: replied 1 month ago.
BTW - the shortblock install was under a very old head gasket oil leak recall
Expert:  Toyota Service replied 1 month ago.

Hello. Welcome to Just Answer. Please allow me to assist you. If this vehicle was in my shop, the very first thing I would be checking would be the cam timing. If the timing belt is off just one tooth, the engine is going to run poor. Has this been checked, and, would you happen to know if the check engine light is on when the engine is running? Please advise. Thanks

Customer: replied 1 month ago.
Check engine light is not on
I assume the dealer installed new belt correctly as part of the engine rebuild
Expert:  Toyota Service replied 1 month ago.

We have had techs replace timing belts in our shop only to find that they installed it one tooth off. This is an honest mistake. It is a frustratingly sad mistake, but it does happen. I would have it checked. No check engine light on rules out a lot of electrical possibilities, so, the issue has to be mechanical.

Customer: replied 1 month ago.
in idle engine runs smooth - even when i rev it up- problem only starts when i put it in gear and start driving
Expert:  Toyota Service replied 1 month ago.

Assuming the engine 'is' in proper time, the next thing I would be looking at would be the advance mechanism on the distributor. If the distributor is not advancing the spark timing, the acceleration would be compromised. Getting back to the timing, the engine will idle with the cams out one tooth, but, the acceleration will be severely compromised.

Customer: replied 1 month ago.
i'll have to check then the timing marks - how hard is it to look at them without removing the radiator hose ?
Expert:  Toyota Service replied 1 month ago.

Let's do this the easy way first: Can you set the crankshaft pulley to TDC, then remove the distributor cap? Then look and advise exactly where the end of the rotor is pointing in relation to the number one cylinder spark plug portion of the cap.

Customer: replied 1 month ago.
ok - i'll do that in a bit - and update you
Expert:  Toyota Service replied 1 month ago.

ok, that will tell us something. Maybe not everything, but it is the easiest

Related Toyota Questions