How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Auto Technician
Category: Toyota
Satisfied Customers: 773
Experience:  16 years of experience
Type Your Toyota Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

Dash lights out, Must push off button for several secounds

Customer Question

Dash lights out, Must push off button for several secounds to turn off at times, MFD shows no readings in energy mode but normally all seem to come back when I disconnect battery to reset compter.
JA: Have you checked the fuses? The dashboard bulbs?
Customer: The dash board comes back after disconnecting battery for 30 sec. and reattaching.
JA: What is the model/year of your Toyota?
Customer: 2004 prius
JA: Are you fixing your Prius yourself? What have you tried so far?
Customer: Yes probably
JA: Anything else you want the mechanic to know before I connect you?
Customer: I have taken out MFD and cleaned the contacts and reinserted and reassembled.
Submitted: 20 days ago.
Category: Toyota
Expert:  Chad Farhat replied 20 days ago.

Hi, I'm Chad. Welcome to JustAnswer. I'm reviewing your question and I will be posting your reply ASAP.

Expert:  Chad Farhat replied 20 days ago.

hey how are you

it is a common problem

send it out & get it rebuild

this a link on ebay i used them 10s of times always good rebuild so far

Please let me know

Thank You

Chad Farhat

ASE Certified Technician

Customer: replied 20 days ago.
Send what out to get it rebuilt? and why in detail how can double check that that part is the problem and not another. Before going forward. My problem is intermittent. Please Toyota knows a lot about this problem it and surely knows how to reproduce it. From what I have read it may be a problem with pin 59 and/or 60 in the MFD not having a good connection.
Expert:  Chad Farhat replied 20 days ago.

sorry i can trouble shoot for you on here for the time it takes to do that

i will opt out for another expert maybe they can help

Customer: replied 20 days ago.
I was upset that I did not get the kind of answer I was looking for. Upon further review. I fully respect your answer as being reasonable. I am also new to this web solution format. I would now rate your service 4 stars. Seeing it was not as robust as I wanted being the detail analytical type of person I am. Having trouble assigning rating to your answer by question.

Related Toyota Questions