How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Auto Technician
Category: Toyota
Satisfied Customers: 43972
Experience:  16 years of experience
Type Your Toyota Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

No hot air and rear blower not working, cold air and no

Customer Question

no hot air and rear blower not working
JA: Do the vents feel cold? Is there a coolant leak?
Customer: cold air and no collant leak
JA: What is the model/year of your Toyota?
Customer: 06 sienna xle
JA: Are you fixing your Sienna yourself? What have you tried so far?
Customer: I had a coolant flush. made sure there was coolant in resevoir
JA: Anything else you want the mechanic to know before I connect you?
Customer: no
Submitted: 25 days ago.
Category: Toyota
Expert:  Chris (aka-Moose) replied 24 days ago.

Welcome, I'm Chris (aka Moose) I prefer to work when others don't, I am here around lunch and after dinner till after midnight.

  • Sorry no one has helped yet.
  • This is not an answer to your question, just an inquiry if your still needing/wanting help. Because I believe I can help.
  • Since the blower is not working, that is likely the reason for not feeling hot air. Is the blower missing power or ground?
Expert:  Chris (aka-Moose) replied 18 days ago.

Hello again Chris here,

  • I am following up with you to see if you got everything you needed from my answer.
  • I have not heard back from you, so I assume you were not pleased. We're you pleased with my help?
  • If you were not pleased with my help, please let me know by replying so I can help more.
  • This post is coming up on the 7 day mark where it times out. When a post times out, that means it's no longer on my active list (you reply and I may never know it.)

Thanks Chris

Customer: replied 18 days ago.
The front blower works. Ive replaced thermostat, flushed the system which apparently wasnt that gunky and replaced radiator cap. No hot air coming out when it is set for defroat and heat. Its a digital system
Expert:  Chris (aka-Moose) replied 18 days ago.

At the rear blower is it missing power or ground when commanded on?

Are the heater core hoses hot where they go into the firewall?

I misunderstood that all issues were in the rear.

A possible concern for no heat up front is a blend door actuator faulty.

Related Toyota Questions