How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Auto Technician
Category: Toyota
Satisfied Customers: 773
Experience:  16 years of experience
Type Your Toyota Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

Loss of power when I accelerate. Runs fine on level ground

Customer Question

Loss of power when I accelerate. Runs fine on level ground when I am steady with speed but when I accelerate at stop or any speed it sputters. I have replaced the fuel filter but don't know what is next
JA: Is the fuel filter an external one, or is it inside the tank?
Customer: external
JA: What is the model/year of your Toyota?
Customer: 2001 4runner
JA: Are you fixing your 4Runner yourself? What have you tried so far?
Customer: nothing just the fuel filter and added a injection cleaner to gas
JA: Anything else you want the mechanic to know before I connect you?
Customer: no really
Submitted: 1 month ago.
Category: Toyota
Expert:  Ron replied 1 month ago.

Hello. My name is ***** ***** I am happy to assist you today. Give me just a moment to review your post, and I'll be right back with the help you need.

Expert:  Ron replied 1 month ago.

I would start next with installing a fuel pressure gauge and monitor the fuel pressure while the problem is occurring.

I would also scan the computer system to see if there are any fault codes setting.

Check these for me and post back and we can work from there.

Customer: replied 1 month ago.
Expert:  Ron replied 1 month ago.

Let me know and we can work from there.

Related Toyota Questions