How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Toyota Service Your Own Question
Toyota Service
Toyota Service, Toyota Expert
Category: Toyota
Satisfied Customers: 4535
Experience:  30+ Yrs of auto experience, Award Winning Svc. Manager; Just Answer Customer's Choice Award Winner
Type Your Toyota Question Here...
Toyota Service is online now
A new question is answered every 9 seconds

I was replacing my 2014 tundra factory stereo with an after

Customer Question

Hi, I was replacing my 2014 tundra factory stereo with an after market pioneer head unit. I had disconnected the negative side of the battery during the installation, but I reconnected the battery as I was trying to pair the phone to the stereo and I think I ran the battery; down to low. I put the battery charger on the battery and It doesn't show a complete charge. I started the truck and noticed that my amp meter is showing less than 14 volts, and I do not have turning signals
JA: Have you tested the battery with a voltmeter? And can you see if it's leaking or not?
Customer: No, I didn't check it with a volt meter, but it is not leaking, and this battery is only a couple of weeks old, it had been replaced by the dealership.
JA: Are you fixing your Tundra yourself? What have you tried so far?
Customer: Well I'm at home and I'm trying to figure out what is going on, the only thing that I've seen so far is a low voltage on the gauge and no turn signals, I was hoping to replace maybe a fuze for the turn signals
JA: Anything else you want the mechanic to know before I connect you?
Customer: other than I had the accessories on too long and ran the battery down to low, and then was wondering if that my have caused me to lose my turning signals
Submitted: 1 month ago.
Category: Toyota
Expert:  Toyota Service replied 1 month ago.

Hello. Welcome to Just Answer. Please allow me to assist you. Please advise if the 4-way flashers are operational; thanks.

Customer: replied 1 month ago.
Expert:  Toyota Service replied 1 month ago.

Thank you. The 4 Way flashers and the turn signals are on the same fuse. I suspect a faulty turn signal switch here.

Related Toyota Questions