How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Peter Bagley Your Own Question
Peter Bagley
Peter Bagley, Auto Service Technician
Category: Toyota
Satisfied Customers: 305
Experience:  master tech at Toyota dealer
24571351
Type Your Toyota Question Here...
Peter Bagley is online now
A new question is answered every 9 seconds

2011 Tacoma, 4.0L V6 4x4, Speedometer, Odometer suddenly

Customer Question

2011 Tacoma, 4.0L V6 4x4, Speedometer, Odometer suddenly stopped working and the Check Engine, ABS, Traction Control and parking brake lights are on. VSS sensor in trans replaced today; still have the problem
Submitted: 3 months ago.
Category: Toyota
Expert:  Cary York replied 3 months ago.

Hi, I’m Cary and I’ll be helping you today.
Please understand that I can't smell, hear, or touch the vehicle, so patience is appreciated. Before leaving the site make sure and leave me a rating. You can still reply to me as many times as needed, even after the rating..

If the check engine light is on you should have a code. Have you had it scanned for codes?

Customer: replied 3 months ago.
the code was P0500
Expert:  Cary York replied 3 months ago.

Was it toward the front or rear of the trans. There are 2 different ones.

Customer: replied 3 months ago.
Not sure, it was replaced by a mechanic and he did not specify. I am guessing by the we talked, it was on the rear
Customer: replied 3 months ago.
The mechanic did not feel comfortable going any deeper into the problem, since the replaced sensor did not help
Expert:  Cary York replied 3 months ago.

I will opt out so another expert can help. Someone will be right with you.

Customer: replied 3 months ago.
thanks
Expert:  Peter Bagley replied 3 months ago.

Hello and welcome to just answer and allowing me to assist you.

The P0500 code is very common on the Toyota Tacoma, Toyota Yaris, Toyota Camry, Toyota Tundra, Toyota RAV-4. Before replacing the sensor you should try cleaning the sensor gear and erasing the code. If the light comes back you may have to replaced the sensor. Also if the trans was recently worked on the connector could have been left disconnected or loose. To gain access to this sensor you have to remove the air box and it sits on the top of the differential . Hope this helps you and if you require further assistance I'll be happy to do so.

Expert:  Peter Bagley replied 3 months ago.

the reason those other things are lite up is because when ever the ECU detects a problem it will disable those items for protection. hope this helps you and if you require any further assistance I'll be happy to do so.

Expert:  Peter Bagley replied 3 months ago.

here is a pic of the sensor.

Customer: replied 3 months ago.
Thank you. A mechanic replaced the vss on the transmission today, but no success. Still have the problem
Customer: replied 3 months ago.
Is there more than one sensor? The mechanic did not mention it, if there is
Expert:  Peter Bagley replied 3 months ago.

there is one on the front diif as well that's senor 'A"

Customer: replied 3 months ago.
Thanks for the information, I did not know that
Expert:  Peter Bagley replied 3 months ago.

and the one in the speeds head

Related Toyota Questions