How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Peter Bagley Your Own Question
Peter Bagley
Peter Bagley, Auto Service Technician
Category: Toyota
Satisfied Customers: 203
Experience:  master tech at Toyota dealer
Type Your Toyota Question Here...
Peter Bagley is online now
A new question is answered every 9 seconds

My 2007 Sequioa rear air suspension seems to be pumping a

Customer Question

My 2007 Sequioa rear air suspension seems to be pumping a lot more then it used to. When starting the vehicle it pumps up to level position sometimes about 75% of the time and after driving it it pumps up again. But other times is doesn't lose any air.
Submitted: 2 months ago.
Category: Toyota
Expert:  Genchi Genbutsu replied 2 months ago.

Thank you for allowing me to help you with this concern today and am sorry to hear that this is happening. I will have to ask you a few questions so that I can get a better understanding as to what may be going on with your Sequoia.

There are two things you can do to help narrow this concern down.. 1) have you checked for any codes stored in the computer yet? (if yes, what codes did you get?) and 2) Have you used a spray bottle with soapy water in it to spray the pump, lines and their connections and the air bags themselves?

Customer: replied 1 month ago.
The code I have is P0016, and I have VSC OFF, VSC TRAC, CHECK ENGINE Indicators on the dash board. I did soap everything I could see and reach. I didn't do the top connection on the air bags as I couldn't see them anyways. Sorry for taking so long to get back with my reply.
Expert:  Peter Bagley replied 1 month ago.

Hello and welcome to just answer and allowing me to assist you. first off the code you have is referring to the camshaft position sensor A actuator bank 1. and the the other items VSC AND TRAC will be disabled by the ECU when it detects a fault code. Now getting to your ride height control problem. Sorry to say you may have to take into a shop that has a scanner that reads the rear ride height sensors because if they loose calibration or malfunction the ride height ECU doesn't read properly what to do. It could just be they need adjusting and that also needs the scanner to do. It's not uncommon these sensors to act up.Hope this gives you some direction to go and resolve your problem. Ifd you require further assistance I;ll be happy to do so.

Customer: replied 1 month ago.
Peter, I haven't had time to take the Sequioa to the dealer yet. But I did just notice that the front struts lower bushing is worn out and the mounting bolt is all the way up thru the rubber bushing. Would that make the level sensor read erratically ?