How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Peter Bagley Your Own Question
Peter Bagley
Peter Bagley, Auto Service Technician
Category: Toyota
Satisfied Customers: 204
Experience:  master tech at Toyota dealer
Type Your Toyota Question Here...
Peter Bagley is online now
A new question is answered every 9 seconds

I had to replace entire upper bracket on steering section of

Customer Question

Hello ,
I had to replace entire upper bracket on steering section of a 1998 4 runner. ( new assembly with new switch and switch " key switch mech" etc. All of that is working for for I can tell. Key works steering lock and acc etc but when I turn to crank I get nothing. Also the factory alarm ( little red light to left of steering wheel keeps flashing. I had to pull fuse to horn before neighbors shot me. Is there a way to re-set alarm? or disarm it? I've drove truck for years now with a basic key so it did not have a chipped key etc , so by me putting a new ignition key assembly, I would think this electrically was not causing the alarm feature. Help.. I cant really afford to put this in shop and its my only ride.
Submitted: 2 months ago.
Category: Toyota
Expert:  Peter Bagley replied 2 months ago.

Hello and welcome to just answer and allowing me to assist you. What was the reason you had to replace those parts? did the electrical problem occur before or after you replaced the parts? It is quite possible the ignition switch is not compatible with your production date, if you look at the ignition switch connector does it plug right into the switch or a short wire harness just before the switch? If it has a short wire harness the colors on the vehicle's wire harness side should match the ones on the switch side.if it plugs directly into the switch check that all connectors match up. or better still if you still have the old switch reattach it to the harness and try that, if all works then that's the problem replace the switch with either the old one or the right one for your vehicle.Hope this helps and if you require more assistance I'll be happy to do so.

Customer: replied 2 months ago.
It was a direct connector. the original issue was inside the bracket that the switch mounts too. The shaft connector rod that goes from switch to key assembly broke. I ordered all directly from Toyota using the VIN number. The ignition portion itself appears to work. The problem if the system security keeps going off if I attempt to open door and or crank it.... I believe this is whats keeping it from cranking and no there was nothing electrically wrong prior to replacing switch/bracket/Key mechinism
Expert:  Peter Bagley replied 2 months ago.

just for the sake of argument can you just reattach the old ignition to you vehicle and try that . did you disconnect the battery when you did the repair?

Customer: replied 2 months ago.
battery was disconnected each time..I will take it back off and put old switch on. I'd love to pay the 26 bucks to talk
but I'm 300 into this now and out of work so be patient with emails......
Customer: replied 2 months ago.
I hope you can help me get this going... and I do appreciate your responses. give me 30 and ill swap Ignition switch.Kevin Simpson
Bethelehem Ga(###) ###-####
Expert:  Peter Bagley replied 2 months ago.

I'm retired so I know where your coming from not to worry, sorry but I have to step out for a bout 30 min be back soon.

Customer: replied 2 months ago.
Tried swapping switch ... same thing... The alarm is killing it somehow .

Related Toyota Questions