How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Auto Technician
Category: Toyota
Satisfied Customers: 773
Experience:  16 years of experience
Type Your Toyota Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

Low horn sounded bad then stopped. I do have the relay click

Customer Question

Low horn sounded bad then stopped. I do have the relay click when pushing the horn. So I replaced the horns , both with new Toyota horns but still nothing. I will try then horn pad connection next I guess.
JA: How many miles are on the car? Has the car been starting normally?
Customer: Yes 150k.
JA: What is the model/year of your Toyota?
Customer: 2008 highlander sprot.
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: Replaced the horns , new factory horns, I have a clicking in the fuse box, but I am going to check the latch sensor, it has failed 2 times before.
JA: Anything else you think the mechanic should know?
Customer: no thank you.
Submitted: 2 months ago.
Category: Toyota
Expert:  George H. replied 2 months ago.

Hello I will help,

Do you have a voltmeter to check the circuit if I guide you?

Customer: replied 2 months ago.
Dissemination regard, found a broken wire. Re connected and it works . Thanks
Expert:  George H. replied 2 months ago.

That is pretty good, you only asked the question 9 minutes ago. Let me know if I can help in the future

Related Toyota Questions