How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Auto Technician
Category: Toyota
Satisfied Customers: 43964
Experience:  16 years of experience
Type Your Toyota Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

Signal and tail light not working, Fuse keeps popping, 2005

Customer Question

Signal and tail light not working
JA: Have you checked the bulbs? Have you checked the connection?
Customer: Fuse for tail keeps popping
JA: What is the model/year of your Toyota?
Customer: 2005 Toyota Tundra
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: Replacing the fuse but it pops after I turn the switch
JA: Anything else you think the mechanic should know?
Customer: I changed the bulbs on my signal lights before this happened
Submitted: 3 months ago.
Category: Toyota
Expert:  Chris (aka-Moose) replied 3 months ago.

Welcome, I'm Chris (aka Moose) I prefer to work when others don't, I am here around lunch and after dinner till after midnight.

I get the rear tail lights used is blowing the fuse.

Do the rear brake lights work?

Do the front parking/running lights work?

You mentioned signal not working but did not go into detail on that?

Expert:  Chris (aka-Moose) replied 2 months ago.

Hello again Chris here,

  • I am contacting you because the post has not been closed out/completed.
  • It appears you were not pleased with my help.
  • If more assistance is needed, reply and let me know, also let me know what it is you're needing to be pleased.
  • This post is coming up on the 7 day mark where it times out. When a post times out, that means it's no longer on my active list (you reply and I never know it.)
  • You have already paid the fees to get this question answered, and I do not want you to leave having paid for something that did not meet your wants/needs and myself not receiving a feedback selection from yourself.
  • So far far this looks to be a wiring issue that we need to diagnose

Thanks Chris

Related Toyota Questions