How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Auto Technician
Category: Toyota
Satisfied Customers: 828
Experience:  16 years of experience
2499435
Type Your Toyota Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

I have a 1993 Toyota corolla 1.6 I have changed everything

Customer Question

I have a 1993 Toyota corolla 1.6 I have changed everything accept relay or ecm.I can put power on fuel pump and it works,but wont work with wiring harness
Submitted: 6 months ago.
Category: Toyota
Expert:  david craig replied 6 months ago.

Hi Im David, sorry about your issue. if you jumper the fuel pump relay will it run?

Customer: replied 6 months ago.
will replacing it fix it also, and,is it the one behind the dash
Expert:  david craig replied 6 months ago.

it should be in the engine compartment

Expert:  david craig replied 5 months ago.

any luck?

Customer: replied 5 months ago.
no,it is behind the radio in the dash. I got it out ,but,which one do I jumper. the one under hood is for ecm ????I am about to the end of my patients
Expert:  david craig replied 5 months ago.

hang on. let me pull up a print

Expert:  david craig replied 5 months ago.

its called a circuit opening relay??

Expert:  david craig replied 5 months ago.

you can try this also

if your pump isn't running, there is a test port in the engine bay in a black box on the passenger wheel well or near the OBD port. use a jumper and connect terminals Fp and +B and then turn your key on. that bypasses all the relays. if you pump doesn't run jumped, it's your pump or it's connections on top of the tank. if it does run, look at the relays, efi main fuse, AFM(or)MAP, the fusible link, all efi related connections under the hood. the o2, egr, and water just make it run funny. at worse limp mode. don't think they will make the ecu shut things down.

Customer: replied 5 months ago.
thanks man..the pump works and its the 2nd new one I put in.I can put power on it and car runs fine but not on its own,I put in NEW complete dist. all injectors fuel pump fuel filter. this is a 93 model car but I got so much in it now I need to get it running.I checked the green 5 prong circuit opening relay with ohm meter and I get reading,can it still be bad???? maybe the EFI relay bad ????
Expert:  david craig replied 5 months ago.

basically when it comes down to relays, you check the relay base to see if you have 12 volts in and then jump that 12volts to the "out" contact and see if tyhe pump works, or find a relay with the same part number and swap them, there are really no known good ohm reading to see if the relay is bad

Expert:  david craig replied 5 months ago.

hows it going with the troubleshooting?

Customer: replied 5 months ago.
I am going to replace the relay under dash (open circuit relay) and the one in engine compartment , I think its called an ignition relay, when I put them in I will let you know what happens.If that don't do it I must have a broken wire somewhere. ???? all of the problems started with a bad coil .
Expert:  david craig replied 5 months ago.

lets cross that path if we get there my friend

Expert:  david craig replied 5 months ago.

any progress?

Customer: replied 5 months ago.
no,I have a new complete dist. all 4 injectors plugs and wires,new ignition relay,fuel relay(behind radio in dash) new fuel pump. what else can I change ? does the wireing harness have a place prone to breaking ? is there anything else I can try ? or do I cut my loses and call salvage yard to come get it. LOL but not too funny
Expert:  david craig replied 5 months ago.

let me dig into the wiring diagram....

Expert:  david craig replied 5 months ago.

heres a print

Expert:  david craig replied 5 months ago.

another one with the fuel pump

Customer: replied 5 months ago.
can the engine run with a hot wire to fuel pump IF the ECU is bad ?
Customer: replied 5 months ago.
could I have NOT got something wired back together when changing fuel pump ? .....now the fuel gauge don't work
Expert:  david craig replied 5 months ago.

thats a real possibilty

Related Toyota Questions