How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dan Your Own Question
Dan
Dan, ASE Certified Technician
Category: Toyota
Satisfied Customers: 1405
Experience:  Dealer Auto Technician
94707146
Type Your Toyota Question Here...
Dan is online now
A new question is answered every 9 seconds

I have a 2008 4 runner w/4.7. Replaced timing belt now have

Customer Question

I have a 2008 4 runner w/4.7. Replaced timing belt now have DTC P0011. Have checked OCV and have 7.4 ohms across terminals and spool does retract when 12volts applied. Your thoughts?
Submitted: 4 months ago.
Category: Toyota
Expert:  Master Auto Tech. replied 4 months ago.
I'm sorry you are having problems with your vehicle. I will try to help.I'm a full time mechanic and have been a mechanic for over 20 yrs and I work part-time here on JustAnswer to help you and others repair their own vehicles, and I get credited by your ratings.. So before leaving the site make sure and leave me a rating. You can still reply to me as many times as neeed, even after the rating.. I will need for you to be my hands and eyes since I'm not there.It determines the timing of the vvt by reading the cam and crank sensors. So if you accidentally got the belt off and advanced the cam that way it would set the code too.Double check and make sure the t-belt is dead on.Let me know if you have any questions.Thanks
Sonny
Customer: replied 4 months ago.
I've checked valve timing numerous times.it is dead on. No question.
Expert:  Master Auto Tech. replied 4 months ago.
Ok well since I haven't seen one just start after doing a t belt I'll opt out.
Customer: replied 4 months ago.
Thanks for your time.
Expert:  tims auto repair replied 4 months ago.

Hi, My name is ***** ***** for the delay.

I will do my best to assist you.

the vvt valve may just be dirty,,remove and clean the screen with carb cleaner..

i will give you some tests/checks for this code..also,again,make sure everything is in time sense it did give this code after replacing the belt

thanks

PLEASE COPY AND PASTE the link below to your browser, I have uploaded more info on this there please copy and paste the link below to your main browser[INTERNET EXPLORER or FIREFOX]

.

https://www.dropbox.com/s/lhdg0db7owc4l2o/0714-4runner-2UZ.doc?dl=0

.

if the link doesn’t work that way, try it this way

thanks

.

www.dropbox.com/s/lhdg0db7owc4l2o/0714-4runner-2UZ.doc?dl=0

.

If you are satisfied with my answer, Please Rate my answer by clicking the rating button so I can get credit for my work. I’m not always going to be giving you good news, so please don't let this stand in the way of you accepting my answer. .it does not cost you more money and we will still be able to communicate, ,.please understand, i can not see, hear or touch the vehicle and only know what you tell me. Bonuses and positive feedback are appreciated.. if you are not satisfied with my answer, please do not leave bad feed back ,i will gladly opt out and let another expert handle the question. .if i have sent any diagrams, please print them. .sometimes you may need to right click the image [,then save picture as]to save it to your computer so you can open it with your picture program...Please ask if you need more help

Customer: replied 4 months ago.
Ive cleaned and tested the ocv. The timing belt is correct. Thats what throws me we've triple-checked this over and over.
Expert:  tims auto repair replied 4 months ago.

ok..follow the tests i gave you

thanks

Customer: replied 4 months ago.
I seemed to have sorted the P0011 code ( bad plug ) now I have a P0345 code, camshaft position sensor "A" circuit ( bank 2 ). Where is the sensor on bank 2? Mitchell on demand and all data do not even show a cam position sensor on bank 2
Customer: replied 4 months ago.
Sorry Tim, I don't mean to be all over the place but my tech didn't have the cam sensor plugged in. Once he did P0011 and P0021 popped there ugly heads up again. I'll get back to you after testing.
Expert:  tims auto repair replied 4 months ago.

ok,please do

thanks

Customer: replied 4 months ago.
Hey Tim, I've run all the tests I can but I do not have an oscilloscope. I can command the valve timing to advanced with my Snap-on scan tool which causes the engine to idle terribly.
Customer: replied 4 months ago.
We have checked valve time and again the timing marks are dead on.
Expert:  Dan replied 4 months ago.

New expert here.

No one has said anything about the engine oil. Have you checked the oil level and condition?
I have seen aftermarket oil filters cause these codes as well, they filter too much restricting the flow. Which sets the code.

Please reply to this if you need more help, then we can continue this conversation. Please rate at the top of the screen. Rating does not close out your question. Remember, sometimes it is difficult to completely diagnose your vehicle without being there, but I will try to give you the best answer I can.

Thanks Dan

Customer: replied 4 months ago.
Hey Dan, the oil has been changed with a Wix filter. Some history on this job. Vehicle came in with bad timing belt. Vehicle very well maintained. Replaced belt, waterpump and all valves. Also replaced OCV filters on both sides. Checked OCV's with digital ohm meter then cycled both with 12 volt power. All tests pass. Vehicle is running poorly, lacks power and fuel economy poor. Have DTC's P0011 & P0021. Have checked timing marks a dozen times. No exaggeration. Used a Gates timing belt with alignment marks and arrows. Any thoughts would be appreciated. Thank, Kevin.
Expert:  Dan replied 4 months ago.

Can you see the cam phasers moving on the scan tool under live data? You will need to be driving and under some acceleration while watching the scan tool.

Customer: replied 4 months ago.
No Dan I have not checked that as of yet I will do so tomorrow and get back to you. What should my readings be?
Expert:  Dan replied 4 months ago.

I can get the specs tomorrow. I am not at the shop right now.

Customer: replied 4 months ago.
I understand and I'm not at my shop either I will talk to you tomorrow morning thanks again. So far you've been the most knowledgeable of anyone I've spoken to.
Expert:  Dan replied 4 months ago.

You should be able to see the timing advance on the scan tool while driving on both banks.

Expert:  Dan replied 4 months ago.

I am not familiar with wix oil filters. I would put a Toyota one on. That is the easiest thing to try first.