How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Auto Technician
Category: Toyota
Satisfied Customers: 814
Experience:  16 years of experience
2499435
Type Your Toyota Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

2000 Toyota carry no start cam and crank sensor new

Customer Question

2000 Toyota carry no start cam and crank sensor new
Submitted: 7 months ago.
Category: Toyota
Expert:  Edward replied 7 months ago.
Hello, Eddie here and I will do my best to help. Is this a 4 cyl. or v6 engine?
Customer: replied 7 months ago.
4
Customer: replied 7 months ago.
4 cylinder 2.2
Expert:  Edward replied 7 months ago.
Alright, are you sure you have spark to the plugs when cranking? and does the check engine light come on with the key just in the ON position?
Customer: replied 7 months ago.
No spark
Customer: replied 7 months ago.
Yes engine light comes on but no codes
Expert:  Edward replied 7 months ago.
Alright, At the coil packs on the drivers side rear of the engine, (there kind of tucked in there fairly good), We need to check for voltage on the BLACK/RED wire with key ON to both coil packs, you don't get any spark out of any of the plug wires correct? If the check engine light comes on, that means our EFI relay is working, the coils are fired by the ECM. so let's make sure we have power and ground to the coil packs before replacing anything else. If you can check the BROWN wire at the coil packs, that goes straight to ground, so you should get an ohm or less when checking it to chasis groud.
Customer: replied 7 months ago.
4
Customer: replied 7 months ago.
I have power to the coil packs
Expert:  Edward replied 7 months ago.
Alright, do you have or have access to a scanner by chance? Just a key on engine off test would tell us if any codes are stored.
Customer: replied 7 months ago.
No codes
Expert:  Edward replied 7 months ago.
Alright, can you check injector pulse when cranking? that would tell us if the ECM is seeing signal from crank sensor. if you have injector pulse, Also are all the plugs not firing, or just 1?
Customer: replied 7 months ago.
No puse
Expert:  Edward replied 7 months ago.
Alright, do you have 12 volts to one wire at the injector with the key on? And the check engine light does come ON with key ON in the dash correct? I'm trying to make sure the EFI relay is working and if you have power to one wire at the injector with key on, then it is. I'm starting to lean towards the ECM has failed.
Customer: replied 7 months ago.
I got a computer for it does it have to be programed or can I just put it in from junk yard
Expert:  Edward replied 7 months ago.
Let me check, 2000 camry could be either way. give me a few. thanks.
Customer: replied 7 months ago.
Thanks one more ..can bad coil pack cause no spark
Expert:  Edward replied 7 months ago.
it can, but there are two coil packs, so I doubt both would fail at the same time. that's why I would check for spark at every plug, and if you don't have injector pulse. something else is going on. Does your check engine light come ON in the dash with key on?
Expert:  Edward replied 7 months ago.
The security light in the instrument cluster, if you turn the key ON, does it stay ON? or does it flash? it's supposed to go out after a couple of seconds with the key ON. If it blinks or stays on, it's a problem.
Expert:  Edward replied 7 months ago.
What is that light doing?
Customer: replied 7 months ago.
Engine light stays on and red light go's away
Expert:  Edward replied 7 months ago.
You don't have a light that says security on your instrument panel ?
Customer: replied 7 months ago.
No
Expert:  Edward replied 7 months ago.
Alright, You have just a plain bare metal key? or is it plastic on the end of it?
Customer: replied 7 months ago.
Medel
Expert:  Edward replied 7 months ago.
All metal right? if that is the case, then there is no transponder in it.
Expert:  Edward replied 7 months ago.
Can you check and see if one wire is hot to the injectors with key on? If it is, then I would sure try another ECM at this point. You have that ECM from the salvage yard on you now ?
Customer: replied 7 months ago.
Yes I tried and still no spark.should I try coil packs ks
Expert:  Edward replied 7 months ago.
You could try. but I don't want you to spend any more on parts now than you have. You checked all your fuses, and you have power to the injectors with key ON correct, one wire should be hot all the time.
Customer: replied 7 months ago.
Yes and yes
Customer: replied 7 months ago.
I just want a gas can now
Customer: replied 7 months ago.
O and a lighter
Expert:  Edward replied 7 months ago.
loll. don't blow it up yet. I don't know what else to till you to try from here. If you don't have injector pulse, it could be connection from crank sensor to the ECM, it could be a wiring issue, no codes though, so that makes me think all that is good, Check your engine grounds, put a jumper cable from neg. post right to the engine and just make sure that's not it at this point.
Customer: replied 7 months ago.
Thanks man I gonna try tomorrow cause I HAD enough with the car today
Customer: replied 7 months ago.
Ilol let u no tomorrow
Customer: replied 7 months ago.
Sorry last ?..loltonite....could it be the ignition switch
Expert:  Edward replied 7 months ago.
If you have power to the injectors and the dash lights up, I doubt it. Let me know what happens.

Related Toyota Questions