How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Auto Technician
Category: Toyota
Satisfied Customers: 814
Experience:  16 years of experience
2499435
Type Your Toyota Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

The instrument cluster on my 2012 camry is not lighting up

Customer Question

the instrument cluster on my 2012 camry is not lighting up nor are the tach, gas guage, speedometer etcj working.... if it is just a fuse which one do you think it is.
JA: Thanks. Can you give me any more details about your issue?
Customer: just went start it this morning and the lights didnèt come on in the cluster. the open door beeper started to be a steady whine a couple of days ago. The motor runs and the car seems to operate correctly (to the end of the driveway anyway)
JA: OK got it. Last thing — Toyota Mechanics generally expect a deposit of about $20 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 8 months ago.
Category: Toyota
Expert:  Skyvisions replied 8 months ago.

Do you have a voltmeter any reasonable knowledge of how to use it? Do the headlights and taillights work? Do the power windows and power door locks work? Are there any warning lights illuminated in the instrument panel? In other words check engine light brake light vehicle skid control light or similar?

Customer: replied 8 months ago.
i have a voltmeter (im an electrician).....head lights work....tail lights work .......windows work ....open door light works signal lights do not work.....wiper work ...lights on radio cluster work eg fan and lights, ac lights ,radio etc power doors work
Expert:  Skyvisions replied 8 months ago.

Any Aftermarket radios or any installations done to this recently that could cause the instrument cluster to go dark including all the gauges to not work?

Customer: replied 8 months ago.
no
Expert:  Skyvisions replied 8 months ago.

OK, let me look at the wiring diagram and see what our options are and what is common amongst those things that are not working on the display. It is a little busy in the shop just now this may take a few to get everything together.

Expert:  Skyvisions replied 8 months ago.

Just to clarify the fuel gauge temperature gauge speedometer and tachometer do not work along with the cluster being dark correct?

Customer: replied 8 months ago.
correct
Expert:  Skyvisions replied 8 months ago.

OK

Expert:  Skyvisions replied 8 months ago.

Check these fuses to see if they are blown or have 12v to them. 10 A ECU-B NO.1 5A Meter-IG2 15 A turn&HAZ These are all in the fuse box under the hood and are the main power supply to the combination meter. Let me know what you find.

Customer: replied 8 months ago.
i do not see ecu-b 10 amp i will go check the other two
Customer: replied 8 months ago.
found it
Expert:  Skyvisions replied 8 months ago.

What is the results of these fuses?

Customer: replied 8 months ago.
they are all good
Expert:  Skyvisions replied 8 months ago.

do they have 12 volts to them? The fuel gauge reading empty or full? Does the temperature gauge indicate cold or hot? Missing any codes in the computer? When you turn the key to the on position does the yellow check engine light illuminate?

Customer: replied 8 months ago.
i did not check the voltage.....the fuel gauge reads off the scale empty ....temp cold..no light......no check engine light
Expert:  Skyvisions replied 8 months ago.

Do any of the warning lights come on? The ABS light or so on? Do have a code reader to see if it will communicate with the ECU?

Customer: replied 8 months ago.
checked the voltage at the fuses checked and there is 12v. no warning lights come on and i do not have a code reader.
Expert:  Skyvisions replied 8 months ago.

The next step will be gaining access to the back of the combination meter where the plug goes in the combination meter. We need to confirm that the voltage is getting to the wires that are being fed by those fuses if those voltages check okay then the problem is in the combination meter itself. I would for safety sake turn the key to the on position and check the voltage to all of the fuses there may be underlying fuses that feed subsystems that report back to the combination meter also. Even the fuses in the box under the left side of the dash.

Customer: replied 8 months ago.
the only lights that come on in the clusteer area is open door signal and lights on ...high and low beam
Expert:  Skyvisions replied 8 months ago.

You are 100% certain the fuses I listed are good? The 5A meter-ig fuse is the power supply to the check engine light and others. The bezel around the cluster has to come out then unscrew the cluster and pull it.

Expert:  Skyvisions replied 8 months ago.

I have to step out for an hour or so. I will be back on lat this evening.