How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Auto Technician
Category: Toyota
Satisfied Customers: 44494
Experience:  16 years of experience
2499435
Type Your Toyota Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

I have a 2002 Toyota sienna Ce when driving on the gh it

Customer Question

I have a 2002 Toyota sienna Ce when driving on the high it will drop speed holding constant gas pedal
JA: Tell me a bit more about what's going on so he can help you best.
Customer: will also do it with cruise control on
JA: Are you hoping to fix this yourself?
Customer: it acts almost like motor stalls
JA: Is there anything else the Toyota Mechanic should be aware of about your Toyota?
Customer: I am working with a shop on it
JA: Our top Toyota Mechanic is ready to take your case. Just pay the $5 fully refundable deposit and I'll fill the Toyota Mechanic in on everything we've discussed. You can go back and forth with the Toyota Mechanic until you're 100% satisfied. We guarantee it.
Submitted: 8 months ago.
Category: Toyota
Expert:  Skyvisions replied 8 months ago.

Can you give me more detail on what exactly is going on? Did you check for codes in the computer with a scan tool? How many miles are on the vehicle? Any service history recently leading up to this current problem?

Customer: replied 8 months ago.
I had a lean cynlinder on 2 and 4 and one time a vvt code but I did not get the codeI have a 2002 Toyota sienna ce , when driving on the highway with cruise control on or off the engine acts like it stalls but after few seconds it of losses speed it picks back up again . I have change the idle air control motor , tps , and inspected the vvt solenoid
Customer: replied 8 months ago.
it has 160,000 but engine was rebuilt at 145,000
Expert:  Skyvisions replied 8 months ago.

Can you get me the specific code numbers that were set in the vehicle previously besides the lean condition code that should be a P0171 I need the other malfunction code numbers set previously and if it's settings again.

Customer: replied 8 months ago.
it was cleared and I have not seen it again , I would have to put it on the scanner again . Would would cause this problem it does not seem to be related to codes that i have gotten
Customer: replied 8 months ago.
Do you have any ideas In stead of questions?
Expert:  Skyvisions replied 8 months ago.

Based on your last reply it seems as though you're just interested in a cookie-cutter fix all answer. There are none, in order to provide you with a quality answer that will get you on the road again it requires lots of questions to get to a reasonable conclusion. At this point it doesn't seem like that is something your in line for I will opt out so you can work with another expert.

Expert:  Chris (aka-Moose) replied 8 months ago.

Welcome, I'm Chris (aka Moose). Experts aren't employees / agents of Just Answer. We are independent service providers using the Site to sell their Expert knowledge to Customers. I strive to provide EXCELLENT 5 STAR service, let me know what's needed from me so your pleased.

-------------------------------------------------------------------------------------

  1. The previous tech has opted out, would you like me to try and help?
Expert:  Chris (aka-Moose) replied 8 months ago.

Hello again Chris here,

1) When customers come to Just Answer the website and the experts want them to have a great 5 star experience.

2) We also want them to be so pleased that they come back for future needs.

3) I have the feeling you were not pleased with my help and or need me to help more. If so please do reply.

4) I have an option to upload diagrams, repair guides, find a repair facility, or call you if that would help.

Thanks Chris

Customer: replied 8 months ago.
I never got a answer from you
Expert:  Chris (aka-Moose) replied 8 months ago.

You never responded if you would like me to try and help, so I was reaching out to you again to see if you need my help.

Customer: replied 8 months ago.
Sorry went on vacation and was out of touch with email and the only reason I am trying this again is a had a buddy with same nick name back in high school .
Here is the low down on my issuesI had a lean cylinder on 2 and 4 and one time a vvt code but I did not get the code numberI have a 2002 Toyota sienna ce , when driving on the highway with cruise control on or off the engine acts like it stalls but after few seconds it of losing speed it picks back up again it will do this about every 15 seconds to one minute . I have changed the idle air control motor , tps , changed all coils and inspected and cleaned the vvt solenoid . The motor was rebuilt mechanically because of a spun rod bearing and has about 10k miles and I had the transmission gone through at the same time . I had a bad vibration while going into overdrive and I took it back to transmission place and they changed fluid and put some kind of special additive in transmission fluid and it fixed the vibration issue I brought it back when this issue started and they said there was nothing wrong with transmission that they thought it was in computer or ignition system . The strange part is I can pull over and turn off engine wait a few minutes and restart and it will drive fine and when it has the issue it tends to idle a little rough . I have it back on analyzer several times since I changed the tps and idle air control motor and have no codes come up since . I have read a bunch of stuff on line about them speeding up on there own but not what seems to be a loss of power I do not think it is fuel because once you get it over 85 mph when it doing it the problem goes away . Have you ever seen this issue I keep replacing parts that seems to be bad but does not seem to fix the intermittent issue .I was thinking about bringing to to dealership to see if the ecm could be reprogrammed It has not be to dealer since 2007 when I bought it . Thanks For listening to my issues maybe you can help . Thanks Boyd
Expert:  Chris (aka-Moose) replied 8 months ago.

When driving and you start losing speed and power, does the engine misfire or just bog down or act like the throttle is no longer responding?

Customer: replied 8 months ago.
No bog down almost like you lift off the pedal and and depress it again over and over again and it does it with cruise control on and does not set. Any codes in computer
Customer: replied 8 months ago.
if you apply more pedal it picks right back up again like if had let your foot off the pedal
Expert:  Chris (aka-Moose) replied 8 months ago.

Can you have it scanned and give me the codes stored right now.

Customer: replied 8 months ago.
I will get back to you with that info Monday
Expert:  Chris (aka-Moose) replied 8 months ago.

Thanks

Customer: replied 8 months ago.
I final got codes what do you think coils were all replaced 1 year ago almost to day nowPO 300 random multiple cylinder misfire is detected
PO 302 cylinder two misfire detected
PO 304 cylinder for misfire detected
PO 306 cylinder six misfire detected
PO 171 fuel system to lean bank one
PO 174 fuel system to lean bank to PO 770 shift solenoid E FAULT
P1354 VVT SYSTEM FAULT BANK 2
Expert:  Chris (aka-Moose) replied 8 months ago.

The codes point most to a cam timing concern on bank 2 which is effecting the compression and causing these misfires your getting which all happen to be on bank 2. The lean codes can be caused from the cam timing and misfire concerns so that has to be addressed if even needed after getting the VVT bank 2 working right. Do you need the diag steps on 1354?

Related Toyota Questions