How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask roy Your Own Question
roy
roy, import/domestic specialest
Category: Toyota
Satisfied Customers: 4643
Experience:  ASE master tech for 40 years
3506196
Type Your Toyota Question Here...
roy is online now
A new question is answered every 9 seconds

My abs light is on along with the brake light. Obd is saying

Customer Question

My abs light is on along with the brake light. Obd is saying code 34 which is rear left abs sensor. The front and rear left sensors are the same so I swapped them to see if the code would change to the front right. After swapping the sensors obd still says rear left sensor which now makes me think its something else other than the sensor.
Submitted: 9 months ago.
Category: Toyota
Expert:  roy replied 9 months ago.

good evening my name is ***** ***** I will assist

since you replaced the sensor, there is the tone ring that may be damaged or a wiring issue. inspect the connector for any damages pins. follow the harness to be sure there is no damage further up the car.

Roy

Customer: replied 9 months ago.
The light often goes on and off and I noticed when it does my speedometer jumps around and also I feel the rear breaks applying even though im not pressing the brakes
Expert:  roy replied 9 months ago.

sounds like the tone ring or dirty mounting area for the sensor

Roy

Customer: replied 9 months ago.
Is the tone ring something I can easily replace or just clean it?
Expert:  roy replied 9 months ago.

is it part of the axle or the hub bearing??? cannot be cleaned. if it is damaged, it will have to be replaced

Roy

Expert:  roy replied 9 months ago.

how are you making out

Customer: replied 9 months ago.
I haven't had a chance to look into it yet. Got busy with work. As soon as i look into it (tomorrow) ill let you know. Thanks your helping!
Expert:  roy replied 9 months ago.

no problem will be here

Roy

Customer: replied 9 months ago.
Looker into the tone ring today. Seemed to be pretty clean and no debris. I also took a dremal tool and sanded the abs mounting surface clean so there wasn't any rust or corrosion. After all that I cleared my abs codes and started it. The abs light went off and then I took it for a drive. About a mile or two of driving the light came back on. So I went home and then later this evening the light went off. Not sure what's going on.
Customer: replied 9 months ago.
Looked *
Expert:  roy replied 9 months ago.

did you replace the sensor??

Roy

Related Toyota Questions