How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ted Ritter Your Own Question
Ted Ritter
Ted Ritter, Toyota Master Tech
Category: Toyota
Satisfied Customers: 4182
Experience:  Toyota Master Tech, ASE Certified
1279120
Type Your Toyota Question Here...
Ted Ritter is online now
A new question is answered every 9 seconds

Mornin, my vsc and abs lights came on after I had a

Customer Question

Mornin, my vsc and abs lights came on after I had a suspension leveling kit put on my 04 4Runner, also the speedometer stopped working.
Submitted: 10 months ago.
Category: Toyota
Expert:  Ted Ritter replied 10 months ago.

Hello, thanks for posting

Without having any specific diagnostic codes for the vsc system it's a little hard to pinpoint the exact problem but it's most likely one of the wheel speed sensors. There is one on each wheel and the computer needs speed information from each one and sends this information to the speedo, if there is a difference between any of the sensors from the rest the warning light turns on.

It's very likely that one of the thin sensor wires from the sensor to the wire harness was stretched and broken inside the insulation during the suspension work, I would recommend taking it back and letting them know that this happened right after they worked on it, they should at least diagnose it and let you know what needs to be done, I've seen this happen many times so that's my opinion on this. If you'd like you can let me know the diagnostic code and I casn be a lot more specific with my answer,.

Customer: replied 10 months ago.
You were right, j checked the the wiring underneath the front wheel well and it was a wire. This was before I even got a response back from you. I had a feeling that I should check. Now the harness has been replaced, but the vsc lights are still on, that just requires a reset of the comp, yes??
Expert:  Ted Ritter replied 10 months ago.

You can try clearing the fault by disconnecting the battery for a couple of minutes. If it doesn't I'll need specific code information to diagnose further.