How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ted Ritter Your Own Question
Ted Ritter
Ted Ritter, Toyota Master Tech
Category: Toyota
Satisfied Customers: 4182
Experience:  Toyota Master Tech, ASE Certified
1279120
Type Your Toyota Question Here...
Ted Ritter is online now
A new question is answered every 9 seconds

Ok bingo on most of this.. 2002 toyota 4runner 2wd. all the

Customer Question

ok bingo on most of this . . 2002 toyota 4runner 2wd. all the lights are on ABS BRAKES ETC. i took it to autozone and the put their computer on the battery and the battery was bad. the battery was only a year old and i had it replaced. Les Schwab installed a new battery and hooked to a snapon diagnostic hand held and it gave the code p0500 A . . the rep said speed sensor. I replaced it and all the lights are still on and the spedo still doesnt work
Submitted: 11 months ago.
Category: Toyota
Customer: replied 11 months ago.
i read online the speed sensor can cause all the lights to stay on abs traction control break check engine. so i replaced the speed sensor after schwab told me the code was p0500 and that did nothing . i checked the connection and the wires appear to be fine. the transmission shifts fine infact it runs fine just has lights on.
Expert:  Ted Ritter replied 11 months ago.

Thanks for posting

The diagnosis for the speed sensor is correct for this code, I assume you replaced the one in the transmission but there is another speed sensor built into the speedometer which sends speed information to the computer, since the speedo is not working the computer sees no information from it and turns the light on. The transmission sensor sends speed signals to the speedometer first then to the computer, the sensor in the speedometer is not replaceable seperately so the speedo assembly needs to be replaced, not the whole cluster, just the speedometer part.

Customer: replied 11 months ago.
that sensor would code P0500 also? and maybe i have a spare speed sensor LOL. how difficult is it to get to replace the the speedometer part and do you happen to have a part number ?? if I'm under standing this if I replace another part the lights will go out?
Expert:  Ted Ritter replied 11 months ago.

To replace the speedo assembly the gauge cluster has to be removed and opened up from the back to get the speedo out. The code is set when the computer fails to see a speed input signal, although the transmission speed sensor is the most common part to fail it is possible that the speedometer sensor is the cause since it receives the signal from the transmission sensor, the transmission sensor sends an analog waveform to the speedo sensor which converts this into a square wave that the computer can read. The only other problem I have seen cause this is a stripped gear on the transmission sensor drive gear inside the transmission which is very uncommon. Once the speed sensor code is fixed the other lights will go off, when there is an input signal malfunction to the computer (ECM) the other systems like abs and traction control become disabled, this is so by design.

Related Toyota Questions