How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Auto Technician
Category: Toyota
Satisfied Customers: 901
Experience:  16 years of experience
2499435
Type Your Toyota Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

2003 Rav4 with 2.0 vvti engine. Had a sludge problem have

Customer Question

Customer: ***** *****, 2003 Rav4 with 2.0 vvti engine. Had a sludge problem have flushed engine twice. Cleaned out pickup tube which was full of gunk. Replaced that VVT sensor that the oil passes thru that controls the timing advance which was completely jammed with sludge. Changed oil and filter 4 times in last 500 miles. Checked VVT sensor again yesterday to make sure it wasnt full of sludge it was pretty clear. At idle the oil light consistently flashes but goes out as soon as the vehicle is underway. The car drives normally but may have a slight rapping heard at takeoff from start. Waddya think?
JA: Thanks. Can you give me any more details about your issue?
Customer: I think thats all I know.
JA: OK got it. Last thing — JustAnswer charges a fee (generally around $20) to post your type of question to Toyota Experts (you only pay if satisfied). There are a couple customers ahead of you. Are you willing to wait a bit?
Customer: ok
JA: OK. Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 1 year ago.
Category: Toyota
Expert:  Joe Barfield replied 1 year ago.

Hello , If your in the U.S. id like to call you....Thanks Joey