How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mastertech 1 Your Own Question
Mastertech 1
Mastertech 1, Toyota Technician
Category: Toyota
Satisfied Customers: 2261
Experience:  ASE Master Technician with over 30 years of experience, including Toyota and Toyota Hybrid.
24034660
Type Your Toyota Question Here...
Mastertech 1 is online now
A new question is answered every 9 seconds

Just installed a CAI on my 94 4Runner, I have double checked

Customer Question

Just installed a CAI on my 94 4Runner, I have double checked everything, but now my engine won't turn over. What should I try?
Submitted: 1 year ago.
Category: Toyota
Expert:  Mastertech 1 replied 1 year ago.

What did you install? Thanks

Customer: replied 1 year ago.
K&N 57-9006 FIPK Performance Air Intake System
Expert:  Mastertech 1 replied 1 year ago.

Ok, then Im assuming it is cranking over, but no run, and you have connected the mass air flow sensor connector? Did you get any kind of a electrial spark from any metal contact during installing this? Take a good look at the fuses in the under hood fuse box to see if any have burned, The large ones and small ones Thanks , please advise on progress.

Customer: replied 1 year ago.
No electrical sparks during installation, I had disconnected the battery beforehand. I will take a look at the fuses. Any ones specifically I should pay attention to?
Expert:  Mastertech 1 replied 1 year ago.

Do you have an aftermarket alarm on this vehicle? And it does crank over but no start correct?

Customer: replied 1 year ago.
I do have an aftermarket alarm. It does crank over, it just won't start.
Expert:  Mastertech 1 replied 1 year ago.

Ok, Then check all fuses, Alarm would cancel out the ability to crank engine, (unless it is a top line viper, or others that cancel out fuel to injectors)

Customer: replied 1 year ago.
Fuses looked good
Expert:  Mastertech 1 replied 1 year ago.

Ok. in the diagnostic test connector under the hood, Open lid you will see on under side of lid is labled, locate the FP and bat. place a jumper between these two connections (like a paper clip or wire, make sure paper clip is not a plastic coated clip) This will turn on fuel pump, then try to start engine

Customer: replied 1 year ago.
Ok let me find something that will work
Customer: replied 1 year ago.
I'm not seeing bat. I see Fp
Customer: replied 1 year ago.
This is what I see
Expert:  Mastertech 1 replied 1 year ago.

+B is the battery (sorry I forgot to include the +) +B to FP Thanks

Customer: replied 1 year ago.
Still won't turn over.
Expert:  Mastertech 1 replied 1 year ago.

You are saying it wont turn (I am assuming you mean the starter turns it over, but no start) Have you checked to make sure that the connector to the igniter/coil are in place? And coil wire is good, You say it ran fine before the fresh air intake was installed correct? This intake uses the factory mass air flow sensor Correct?

Customer: replied 1 year ago.
Correct, the starter turns over but no start. Igniter/coil are in place and coil wire is good. It was running fine until the intake was installed.
Expert:  Mastertech 1 replied 1 year ago.

Have you checked to see if there is a spark coming from a plug wire? Take a long screwdriver insert the steel part into the plug wire boot and place it 1/2 away from metal surface like intake or and crank over engine and see it there is a spark.

Customer: replied 1 year ago.
I will have to try this tomorrow when I can have a friend come over and help, am I still able to message you then?
Expert:  Mastertech 1 replied 1 year ago.

Yes, I will be online, Thanks, ***** ***** great night!

Expert:  Mastertech 1 replied 1 year ago.

I will be on line after 10 mountain time Thanks

Customer: replied 1 year ago.
10 AM?
Customer: replied 1 year ago.
Could a bad MAF cause my engine not to start?
Expert:  Mastertech 1 replied 1 year ago.

Yes it can,

Related Toyota Questions