How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jeromy Madison Your Own Question
Jeromy Madison
Jeromy Madison,
Category: Toyota
Satisfied Customers: 71
Experience:  Owner/Technician at Mad Auto Repair
90693043
Type Your Toyota Question Here...
Jeromy Madison is online now
A new question is answered every 9 seconds

My 1999 toyota rav4 engine turns but won't fire up when

Customer Question

my 1999 toyota rav4 engine turns but won't fire up when engine is warm. some times it starts after 10 tries, and check engine comes on with code p1330. I have changed the ignition coil and the wires and the spark plug, but the problem still exists.
Submitted: 1 year ago.
Category: Toyota
Expert:  Jeromy Madison replied 1 year ago.

Hello, I have seen a similar problem in the past. Please tell me what all you have done to start with.

Customer: replied 1 year ago.
A couple weeks ago i took it to shop to basically replace the cooling system. The car has new water pump, oil pump, radiator, and timing belt. When the igntion issue started to happen, i replaced the ignition coil, and the wires. Checked the spark plugs but they are still new since i changed them in June. Also it has new thermostat and coolant sensor.
Customer: replied 1 year ago.
any idea?
Expert:  Jeromy Madison replied 1 year ago.

Which coil did you replace?

Customer: replied 1 year ago.
I replaced all four wires that connect to spark plug, and the two boxes that the wires attach to on the other end. I have attached the pictures to this reply.
Expert:  Jeromy Madison replied 1 year ago.

Ok. That code is for the igniter in the #1 coil. I know you have replaced that coil, but did you use a denso coil? I only ask because when I saw this problem before it was when a coil was replace with a non-denso (or non-factory manufactured) coil.

Customer: replied 1 year ago.
No, I just bought something that fits it. However, the car starts fine when it is cold and runs well. But if i turn it off, the car won't fire up until it is cold enough. I just want to clear that up because that was the original problem.
Expert:  Jeromy Madison replied 1 year ago.

Yes, I understand. I recommend getting a factory coil. Toyota electronics are very finicky and if it is just a little bit out of spec. it can do this.

Customer: replied 1 year ago.
Ok i buy those from the dealership and let you know the progress
Expert:  Jeromy Madison replied 1 year ago.

Ok, thanks.