How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Toyota Service Your Own Question
Toyota Service
Toyota Service, Toyota Expert
Category: Toyota
Satisfied Customers: 4606
Experience:  30+ Yrs of auto experience, Award Winning Svc. Manager; Just Answer Customer's Choice Award Winner
14892859
Type Your Toyota Question Here...
Toyota Service is online now
A new question is answered every 9 seconds

04 Toyota tacoma I got it new from dealer in 04. Just turned

Customer Question

04 Toyota tacoma I got it new from dealer in 04. Just turned 200.000 miles nothing never wrong till few months ago! The 10 amp fuse keeps blowing that runs fan dash speedo then a red light comes on saying left diff locked. This is a*****truck. ! Iv replaced the fuse it's ok for a while then it blows the battery will run dead if lights are on! The new fuse will blow Iv replaced dozens it's time to fix the problem I can hear the compressor click on hard but it dose it without using the a/C can u help? It's it a short or compressor going out?
Submitted: 1 year ago.
Category: Toyota
Expert:  Toyota Service replied 1 year ago.

Hello. Welcome to Just Answer. Please allow me to assist you. Please clarify exactly what happens when this fuse blows. If I understand you correctly, the instrument panel stops working (speedometer and gauges) and the fan motor stops working., Is this correct? Thanks.

Customer: replied 1 year ago.
it's correct red light comes on saying dif locked it's a 2weel drive
Expert:  Toyota Service replied 1 year ago.

Let's open the relay Panel under the hood, and locate the HEATER relay. Then remove it, replace the fuse, and drive it. I suspect that you might have a bad heater relay. We need to eliminate this (or verify this) to see where our problem lies.

Customer: replied 1 year ago.
That's not it I tyed that all ready ;( no tack speedo. Only light on is red left dash below temp says RR Diff Locked in red????
Customer: replied 1 year ago.
It's a short or fuse bale link?
Expert:  Toyota Service replied 1 year ago.

The 10 amp GAUGE fuse powers the coil side of the heater relay.

Expert:  Toyota Service replied 1 year ago.

If it was a short, the issue would cause the fuse to pop instantly. You have a temporary or slow circuit here. Process of elimination is the way we need to proceed.

Customer: replied 1 year ago.
I tryed pulling the heater relay fuse put new 10amp soon as I tryed to drive it popped the 10 amp! The battery looks like it's been over charging corrosion on cables look to of dropped on senser that is hooked next to battery tray I think it's the impact sencer?? Wires look ok but senser might have got corroded
Expert:  Toyota Service replied 1 year ago.

What color is this sensor? yellow? Bright Yellow wire?

Customer: replied 1 year ago.
Expert:  Toyota Service replied 1 year ago.

Yes. That is your impact sensor. If the wores are corroded you will have a short. This is something you need to be real careful with. If you damage the sockets or the pins, your impact sensor will not transmit a crash signal to the air bag computer. This could have very serious consequences. Try cleaning it out with Spray Brake cleaner before you do anything else.

Customer: replied 1 year ago.
Ok
Expert:  Toyota Service replied 1 year ago.

ok

Customer: replied 1 year ago.
Well as soon I got in the truck fuse popped
Customer: replied 1 year ago.
That's not nothing to do with it should I unplug the compresser ??
Customer: replied 1 year ago.
Could the compresser make it short out the fuse even know I'm not useing the a/c
Customer: replied 1 year ago.
I unplugged the a/c compresser soon I started it the fuse popped agin ?
Expert:  Toyota Service replied 1 year ago.

The compressor is not on that fuse.

Customer: replied 1 year ago.
I know this now
Expert:  Toyota Service replied 1 year ago.

Let's look at this objectively. You replace the fuse and start the truck. The 10 amp gauge blows, and the dash goes out. Additionally, the heater fan is inoperative, correct?

Customer: replied 1 year ago.
What's tripping this 10 amp fuse
Expert:  Toyota Service replied 1 year ago.

The question now is does the fuse blow with the AC/blower off when you start it?

Customer: replied 1 year ago.
Expert:  Toyota Service replied 1 year ago.

That leaves us with the the following items:

Heater: both air servo motors

Instrument panel: The gauges.

The first thing in the Gauge fuse (combination meter side) is the fuel gauge.

Perhaps we need to remove the screws form the front instrument panel fascia, remove the 4 10 MM bolts, pull the instrument panel and disconnect the panel; then try a new fuse. Before we do that, are there any accessories fitted to this vehicle? Aftermarket radio, alarm system, audio amplifier, GPS, things like that?

Customer: replied 1 year ago.
No after market stuff! But all this kind of happen after bumping a curb in a parking lot did not know I was so close as I parked the truck
Expert:  Toyota Service replied 1 year ago.

Both of the units described above are on the gauge fuse (plus the coil side of the heater relay. Perhaps let's disconnect the wire connections at the air box servo motors and retest.

Customer: replied 1 year ago.
Air box servo motors? Is this the air cleaner?
Expert:  Toyota Service replied 1 year ago.

No. The air box that the heater motor blows into The servo motors move the doors inside the air box to the different positions (defrost. floor, center dash, etc)

Customer: replied 1 year ago.
I third that it did not work red light still on in dash says RR Diff LOCK ???? No tack speedo fan motor ????
Customer: replied 1 year ago.
Will the impact senser do this if it went bad??
Expert:  Toyota Service replied 1 year ago.

If the impact sensor was bad your Air Bag light would be on. Looks like we need to pull the instrument panel, disconnect and fit another fuse. We are running out of possibilities.

Customer: replied 1 year ago.
Why just thus truck? Should be a lot of them bad if Iv problems
Expert:  Toyota Service replied 1 year ago.

IF the problem would be due to design, manufacturing or workmanship, other trucks may have similar qualities. This sounds like something has failed and is shorted out.

Customer: replied 1 year ago.
Is the lights on this 10 amp fuse also?
Expert:  Toyota Service replied 1 year ago.

Parking head or taillamps?

Customer: replied 1 year ago.
That's what I'm asking ? Mybe a short in wires to the tail lites or parking lights ?
Expert:  Toyota Service replied 1 year ago.

Back up lights are on this fuse.

Expert:  Toyota Service replied 1 year ago.

If you have daytime running lamps (some do, some do not) the gauge fuse powers a section of the daytime running lamp module.

Customer: replied 1 year ago.
All morning Iv been driving the truck with the dash all apart I was getting ready pull the gage cluster check or unplug it! The fuse has not popped yet! So I was wondering it's Eather when I use lights or a/c fan seams is when fuse blows??
Expert:  Toyota Service replied 1 year ago.

If the fuse blows when you turn the headlamps on, the Daytime Running light controller is most likely the problem

Customer: replied 1 year ago.
DRL controller ?? What's this ?
Expert:  Toyota Service replied 1 year ago.

Dayrime Running Light Controller (sometimes called a DRL module)

Expert:  Toyota Service replied 1 year ago.

This would be located in the center of the dash, around the area under and behind the radio/AC controls.

Customer: replied 1 year ago.
It's a 04 Toyota to tacoma standard work truck no day time running lights on this truck
Expert:  Toyota Service replied 1 year ago.

Reverse lights are on this fuse.

Expert:  Toyota Service replied 1 year ago.

No headlights, no taillights or brake lights. Just Reverse. (if you do not have DRL)

Customer: replied 1 year ago.
No drl
Customer: replied 1 year ago.
Now I'm driving the truck with lights on so far no popped fuse!!
Customer: replied 1 year ago.
Next I'll turn on the fan and A/c
Expert:  Toyota Service replied 1 year ago.

ok

Customer: replied 1 year ago.
what I noticed was the fan only works on high ??
Customer: replied 1 year ago.
Iv tryed everything still dose it
Expert:  Toyota Service replied 1 year ago.

Fan only working on High is an open circuit in the heater fan resistor.

Expert:  Toyota Service replied 1 year ago.

This is the plate with a wire connector on it on the tube between the blower motor unit and the AC box; this would be under the rear of the glovebox area

Customer: replied 1 year ago.
This would pop the fuse ?
Expert:  Toyota Service replied 1 year ago.

if it is shorted out it could.

Customer: replied 1 year ago.
Ok I got the gage cluster out what do I unhook ? Blue plug? White one? Or brown ?
Expert:  Toyota Service replied 1 year ago.

Disconnect the connector with the Black with a red stripe wire.

Customer: replied 1 year ago.
if I unhook cluster no fuse popped it's the cluster is bad ?
Expert:  Toyota Service replied 1 year ago.

one of the components of the cluster....yes

Customer: replied 1 year ago.
10/4 Toyota guy Ty for your help!!;) cowboy dan
Expert:  Toyota Service replied 1 year ago.

You are very welcome. A positive rating for my input would be greatly appreciated. Thanks for choosing Just Answer!

Customer: replied 1 year ago.
Well I thanked u 2 soon Iv been driving without the gage cluster for a day all seamed well till the fuse blew out agin !!! What the heck is wrong. ?? Obviously I can put the dash back together cause I tryed everything u said and it still blows the fuse:(
Expert:  Toyota Service replied 1 year ago.

Disconnect anything with a wire connector under the center of the dash on the air distribution box.

Customer: replied 1 year ago.
Nothing seams to work Iv did what I was told by u what can it be the abs has been unhooked to both front brakes for like 4 years and it always had the abs light on in the dash That never give any problems before I just hate the abs system in these trucks
Expert:  Toyota Service replied 1 year ago.

You did not tell me the ABS was disconnected! Please disconnect the ABS unit under the hood.

Expert:  Toyota Service replied 1 year ago.

You want to make sure that you have the connector with the Black with a blue stripe wire disconnected.

Customer: replied 1 year ago.
Would thus after so long now give problems now after like 4 years and wher under the hood is their a fuse for the abs unit ??
Expert:  Toyota Service replied 1 year ago.

Look for a big thing with a brake lines going to it.

Expert:  Toyota Service replied 1 year ago.

The GAUGE fuse powers the ABS inverter circuit

Expert:  Toyota Service replied 1 year ago.

passenger side inner fender area

Customer: replied 1 year ago.
This would trip the 10 amp fuse Iv been having problems with ?
Customer: replied 1 year ago.
The Barbary is now going dead cause it's not charging cause this fuse keeps going out ! In the day it's ok but last night I went to the store and the Battery drained
Expert:  Toyota Service replied 1 year ago.

Yes. It is not charging if you still have the panel disconnected.

Customer: replied 1 year ago.
I pulled the 30 amp abs fuse ! I'll put new 10 amp and try it let u know what up
Expert:  Toyota Service replied 1 year ago.

You need to disconnect the actuator unit. the ABS fuse is a second fuse for the actuator

Customer: replied 1 year ago.
Ok
Expert:  Toyota Service replied 1 year ago.

ok

Customer: replied 1 year ago.
Abs light still on in dash after I unhooked it ! Check ing light is on I'm going code it see what's up
Expert:  Toyota Service replied 1 year ago.

ok

Customer: replied 1 year ago.
That seam not to work but I did notice the fuse pops when I put in revers?? And now no dash lights??
Expert:  Toyota Service replied 1 year ago.

We discussed this fuse powering the reverse lamps earlier. Reverse comes form the multi-function switch on the side of the transmission. This powers the instrument panel trans position lamps (if you have this option). Your dash lights being inop is ether a poor connection, the dimmer unit is disconnected or the TAIL fuse is blown.

Customer: replied 1 year ago.
Toyota guy I unhooked the sending unit to the tranny that go to back up lights !! So far fuse stays good I put dash all back together and plugged in abs system all is good so what do this mean? Will a back up light being out cause this or is a bad sending unit in the side of the 5 speed tranny! Ty all your help would been lost with out u ! Cowboy dan
Expert:  Toyota Service replied 1 year ago.

If the fuse does not blow, and we have narrowed it to the back up lights, the problem is either in the switch, the wire to the rear, or a short inside the lamp itself. Which it is I cannot say. Since you mentioned early on that the reverse lights have an issue, I would take the lights out and look for corrosion in the sockets. If that is OK, I would ten focus on the switch.

Expert:  Toyota Service replied 1 year ago.

I would also look at the wire harness under the truck for pinches, just to be sure,

Expert:  Toyota Service replied 1 year ago.

If you have any questions, please feel free to reply; I will be very glad to help you further.

If you do not have any questions, and are satisfied with my input on your request, thanks for choosing Just Answer. It was a pleasure to assist you today. I trust my input to your request is satisfactory to you and meets your expectations.

A positive rating would be greatly appreciated for my assistance on your inquiry. If you are especially happy with my input on your request, you can choose to offer me a bonus which also would be greatly appreciated.

Thanks in advance and thank you again for choosing Just Answer

Customer: replied 1 year ago.
K. Ty for your help Toyota guy
Expert:  Toyota Service replied 1 year ago.

You are very welcome Mr. Cowboy Dan

Related Toyota Questions