How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Amedee Your Own Question
Amedee
Amedee, Toyota Technician
Category: Toyota
Satisfied Customers: 24390
Experience:  ASE certified tech advanced level specialist. Wisconsin certified emissions state inspector
279429
Type Your Toyota Question Here...
Amedee is online now
A new question is answered every 9 seconds

Extreme power loss. Engine tries to make power, even pushes

Customer Question

extreme power loss. Engine tries to make power, even pushes rpm s to 4000 yet car wont go. Engine light came on with po420 code popping up then light went out. Changed plugs and mass airflow sensor, changed cat and upstream o2 sensor last year.
Submitted: 1 year ago.
Category: Toyota
Expert:  Amedee replied 1 year ago.

Hello and welcome! My name is ***** ***** I can assist you with your question. What is the engine vacuum at idle and at 2500 rpm?

Customer: replied 1 year ago.
I have no idea- have no way to check it right now
Expert:  Amedee replied 1 year ago.

Ok, no problem. I can wait until you run this test and report back. It does not have to be done today. I will be looking forward to your reply.

Customer: replied 1 year ago.
Not sure if i can do the test today. But took it for a ride yesterday and after a few minutes it couldnt get out of its own way. Put my foot to the floor and it wouldnt even get above 25 on a hill. Kind of hard to explain- no check engine light came on. And I dont think I mentioned that the car just rolled over 200,000 miles and has been running fine till then. I would think that if something like an intake leak was there it would set off a code- someone mentioned that last night.
Expert:  Amedee replied 1 year ago.

Hello! I understand what your trying to explain to me. I have experienced this many many times and I am very good at diagnosing this sort of issue. Was the muffler replaced? If not that can cause this issue as well if it is plugged up. There is no code for "Plugged muffler"

Related Toyota Questions