How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Auto Technician
Category: Toyota
Satisfied Customers: 811
Experience:  16 years of experience
2499435
Type Your Toyota Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

I have a 03 toyota Tacoma ,I disconnected the battery,put

Customer Question

I have a 03 toyota Tacoma ,I disconnected the battery,put new 0 rings and seals on fuel injectors,put on new fuel filter,reconnected the battery cable,now the truck will start when the ignition is in the crank position and quits running when the key goes back to the on position,fire to the pump when key is in crank position but no fire to the fuel pump when in the on position,what could be the problem.
Submitted: 1 year ago.
Category: Toyota
Customer: replied 1 year ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  Ted Ritter replied 1 year ago.

Hello, thanks for posting

With the key on is there voltage to the B+ terminal in the diagnostic check connector? Does the engine keep running if you put a jumper between B+ and the FP terminal? Is it a V6 or 4 cylinder?

Check the EFI fuse and make sure the EFI relay is secured.

Related Toyota Questions