How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask cardoctor71 Your Own Question
cardoctor71
cardoctor71, ASE Certified Technician
Category: Toyota
Satisfied Customers: 670
Experience:  ASE MasterCertified Tehnician with 35 years experience diagnosing and repairing all makes and models of cars and trucks.
36867192
Type Your Toyota Question Here...
cardoctor71 is online now
A new question is answered every 9 seconds

I have a 2010 Toyota corolla le, I bought it used about 4

Customer Question

I have a 2010 Toyota corolla le, I bought it used about 4 months ago. My problem started about 2 days ago. I made a hard left turn and my engine killed. I restarted the car and everything was OK until tonight. After work I tried to start the car and nothing happened, it was like everything died on it. One of my coworkers jumped me off and I was able to drive home. On my way home I turned on my brights, my lights dimmed and all the light signals came on, on the dash. I turned off the brights and everything went back to normal. When I got home I turned off the car and as before it would not start no lights nothing. My husband switched batterys and still nothing. Help please.
Submitted: 1 year ago.
Category: Toyota
Expert:  AZTechBrian replied 1 year ago.

If you try to jump it like last time, will it start?

Customer: replied 1 year ago.
We haven't tried it when I got home. My husband switched out batteries and nothing happened. He seems to think it might be in the connection in the terminals.
Expert:  AZTechBrian replied 1 year ago.

That is my initial thought as well. something may have come loose when you were turning.

Expert:  AZTechBrian replied 1 year ago.

Try shaking the cables and see if the lights come on. I'm sure he already thought of that.

Customer: replied 1 year ago.
He did he also seen that the positive cable was corrosive, he cut it back and reconnected it back. Still wouldn't start. Then we were able to jump it off again. While it was running he disconnected the ground to check the alternator car was still running. We are at a loss.
Customer: replied 1 year ago.
He just let the car run for 15 min. then turned it off it would not start. Nothing happened when he turned the key.
Expert:  cardoctor71 replied 1 year ago.

On newer model vehicles like your 2010 Toyota you should not ever disconnect the battery with the vehicle running to check the alternator, this causes the vehicle anti theft system to disable the vehicle because it thinks the vehicle is being stolen. Once this happens the vehicle anti theft system has to be reprogrammed, as far as the vehicle stalling on a turn the wiring near the steering components needs to inspected for a chafed or broken wire. The vehicle can be jump started but the antitheft system quickly ddisables the injector pulse from the computer, the vehicle stalls or will not start at all. PLEASE RATE my service a 3 or above, if for some reason you can not, PLEASE ask me another question, I will continue to answer your questions even after you rate my service until you are completely satisfied with my answers.