How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask scionking Your Own Question
scionking
scionking, Toyota Expert
Category: Toyota
Satisfied Customers: 469
Experience:  5 YRS EXP. ASE MASTER CERTIFIED/ TOYOTA MASTER CERTIFIED
26789525
Type Your Toyota Question Here...
scionking is online now
A new question is answered every 9 seconds

Im having a reacurring p0770 code on my 96' toyota tacoma

Customer Question

Im having a reacurring p0770 code on my 96' toyota tacoma 3.4l 4wd, Automatic. I've tried just about everything to fix it. After clearing the code it quickly comes back on when quick acceleration is needed to get on the freeway. The transmission seems to be running strong, and smoothly so im wondering if this an electrical problem or maybe the Ecm computer needs to be recalibrated. Also if i try to shift into gear before the truck is fully warmed up there is a strong jerk when passing through reverse and into drive.
Submitted: 1 year ago.
Category: Toyota
Expert:  scionking replied 1 year ago.

Any green corrosion in the transmission harness connector at the transmission?

Customer: replied 1 year ago.
It'll be a couple of days before i can check the harness. The harness should of been the first thing i checked since i've driven my truck through deep water up to the bottom of my door a few times. I'll keep you posted, Thanks!
Expert:  scionking replied 1 year ago.

Yes this would be a good place to start, check the wire harness side, and the transmission plug to, I have seen rotted pins on the transmission side that have caused this type of problem.

Expert:  scionking replied 1 year ago.

Hi do you still require assistance with this issue?

Expert:  scionking replied 1 year ago.

Hi do you still require assistance with this issue?