How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Toyota
Satisfied Customers: 21597
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
9825021
Type Your Toyota Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

Skip. I just changed out the HVAC control unit in my 2007

Customer Question

Hi Skip. I just changed out the HVAC control unit in my 2007 Highlander Hybrid. When I turn on the vehicle, the unit seems to be working fine, but the mode (defrost, foot, etc) doesn't change when I change it on the control panel. It indicated a change on the panel, but the actual blower doesn;t change, it just continues to blow from the dash vents. Additionally, while the auto temp control works, ie, I can change the temp from 65 all the way to 85, the air temp doesn't change at all. I suspect there may be a relay issue somewhere? Could you give me some guidance? Thanks
Submitted: 1 year ago.
Category: Toyota
Expert:  sprinkles08 replied 1 year ago.

Hello and welcome to JustAnswer!

You have a couple different issues going on, one with the mode door and one with the blend door. The issues may be the doors themselves (bound in the heater box or broken), their actuators, or wiring.

What was the original issue that the control head was replaced for, and where did the replacement come from?

Customer: replied 1 year ago.
It was actually the wiring. While waiting for a response I removed the control unit just to double check my installation. Sure enough, I hadn't fully seated one of the connections. Pushed the connection in fully and now it's working like a champ. Thanks!
Expert:  sprinkles08 replied 1 year ago.

Great, I'm glad to hear it!

Related Toyota Questions