How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Toyota
Satisfied Customers: 21601
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
9825021
Type Your Toyota Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

Sure I am having a problem with trailer tail light on my

Customer Question

Sure I am having a problem with trailer tail light on my 1999 land cruiser
Submitted: 1 year ago.
Category: Toyota
Expert:  sprinkles08 replied 1 year ago.

Hello and welcome to JustAnswer!

I'm not showing a factory trailer connector was an option on this and all wiring from the park lamp relay to the lights should be green, so I'm assuming you have an aftermarket harness. Most aftermarket harnesses plug into either the left or right rear tail lamp wiring and then the harness runs down to the trailer plug. If that's what you have and the park lamps on the vehicle do work then you have to have an issue either in the trailer harness or connections.

Have you traced the trailer wiring to see where it connects?

Related Toyota Questions