How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Toyota
Satisfied Customers: 22135
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
9825021
Type Your Toyota Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

Toyota Camry: Ok...replaced fuel pump in a 2007 toyota camry....worked

Customer Question

Ok...replaced fuel pump in a 2007 toyota camry....worked for a few minutes then died....no power again when key is on to pressurize the fuel system
Submitted: 1 year ago.
Category: Toyota
Customer: replied 1 year ago.
Constant 10.5 voltage at pump on one lead but didn't realize that key was not actually on...probably replaced a pump that was working fine. Already put the seat back in...Definitely a fuse, relay or wire issue....Checked all fuses and Relay that are visible....
Customer: replied 1 year ago.
(Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  sprinkles08 replied 1 year ago.
Hello and welcome to JustAnswer!
The wire you're seeing with voltage is almost surely the sensor circuit, it's reference voltage rather than power. the fuel pump would only have power when the key is first turned on or when cranking.
The fuel pump power wire is gray. If there is no power there, fuses and the circuit opening relay are good then you either have a wiring issue or the engine controller isn't awake.
Doe the ECM have communication with a scan tool at the time it won't start? If so, are any codes setting?

Related Toyota Questions