How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Your Toyota Guy Your Own Question
Your Toyota Guy
Your Toyota Guy, Certified Toyota Master Diagnostic Technician
Category: Toyota
Satisfied Customers: 589
Experience:  I have been/am a Toyota technician for 15yrs+.
75929629
Type Your Toyota Question Here...
Your Toyota Guy is online now
A new question is answered every 9 seconds

Tundra Crewmax 4X4 5.7L: , i have a problem with my A/C

Customer Question

Hello, i have a problem with my A/C on an 08 Tundra. i just replaced blower motor. Working fine for first two weeks, now when system is on MAX (fan speed at max) - the blower and A/C shut off after about 10 seconds. I can turn back on and it will run for another 10 secs or so and shut off. I can run A/C indefinitely on any other fan speed.
Submitted: 1 year ago.
Category: Toyota
Expert:  Your Toyota Guy replied 1 year ago.
The problem exists within the A/C amplifier, older vehicle blowers simply ran through a couple of resistors, that varied the resistance and therfore the speed of the blower motor, with modern vehicles such as yours, the speed is controlled electronically, but switching the blower motor on and off repeatedly at various speeds (variable duty cycle) to control the speed. When the A/C amplifier starts to fail you begin to see symptoms such as this.
Expert:  Your Toyota Guy replied 1 year ago.
Let me know if I can help further.