How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Auto Service Technician
Category: Toyota
Satisfied Customers: 24669
Experience:  Over 17 years diagnosing and repairing automobiles various makes and models with some training and certifications.
14928985
Type Your Toyota Question Here...
Pete is online now
A new question is answered every 9 seconds

Highlander: Accidently jump started my 2012 highlander with

Customer Question

Accidently jump started my 2012 highlander with positive on positive due to back rubber cover on pos. terminal.
Fixed the cables and was able to start the highlander. Several check engine lights were on and was in able to throttle engine. Checked all fuses and replaced one. Now, check engine light and TRAC OFF light are on but throttle and everything else appear to be functioning properly.
Manual shows a fuse for ESC and TRAC but it a long orange atypical fuse from what I'm use to.
Any suggestions?
Submitted: 1 year ago.
Category: Toyota
Customer: replied 1 year ago.
Unable to throttle engine * changed fuse that was shorted and that fixed throttle but check engine light still on.
Expert:  Pete replied 1 year ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.
If the jump start occurred with the cables connected back words or incorrectly this will cause this fault here as well as any voltage surge or spike issue.This can damage the engine computer internally and cause this fault here with the computer needing replaced.I would have this tested further to see if the computer is the cause here needing replaced to resolve this issue.
Thanks Pete