How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Auto Technician
Category: Toyota
Satisfied Customers: 814
Experience:  16 years of experience
2499435
Type Your Toyota Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

After running and engine hot

Customer Question

After running for awhile and engine hot I turn off motor an will not fire back up let sit for 2 hours and starts
All plugs spark but no fuel on them
Submitted: 1 year ago.
Category: Toyota
Expert:  Ted Ritter replied 1 year ago.
Thanks for posting
Is it getting voltage to one of the wires to the injectors? Just check the one you can get to, each injector has to have 12 volts or so to one wire with the key on, the other wire is grounded by the computer to turn the injectors on and off, check this during the time the engine won't fire. Another problem could be loss of ignition signal, if the computer loses spark confirmation the injectors are turned off.
Have you checked for diagnostic codes using the check connector under the hood?
Customer: replied 1 year ago.
Please cancel this answer. It came to late and I spent several hours stuck at an interstate gas station and finally fixed problem myself. I never received an email from you at all.

Related Toyota Questions