How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Auto Technician
Category: Toyota
Satisfied Customers: 814
Experience:  16 years of experience
2499435
Type Your Toyota Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

Tacoma 3.4: 02 Tacoma 3.4 truck came in running we did timing

Customer Question

02 Tacoma 3.4 truck came in running we did timing belt kit water pump seals
Everything oem.now truck won't run has compression spark and noid lite works when trying injectors.i removed spark plugs and they are flooded with gas,Note. Truck was running perfect.
Submitted: 1 year ago.
Category: Toyota
Expert:  Skyvisions replied 1 year ago.
Are you getting any malfunction codes set in the engine control computer? What is the compression numbers at? Will the spark jump at least a quarter of an inch from the end of the ignition coils?
Customer: replied 1 year ago.
150 all around,no codes
Customer: replied 1 year ago.
Good blue spark
Expert:  Skyvisions replied 1 year ago.
150 PSI is a little on the low side this engine should easily do 170 and even 180 PSI is normal. Are you 100% certain that the timing belt is installed correctly when it is at TDC #1 are both your camshaft marks are lined up correctly? What type of code reader are you using to check for codes?
Customer: replied 1 year ago.
Yes checked 3 times already.cam marks and crankshaft are rite on spot,engine sound when turns with pretty good compression,snap on modis ultra,it's 5 o'clock over here I'll get to you as soon as get to the shop
Expert:  Skyvisions replied 1 year ago.
OK a picture of the cam marks at tdc would help. When the key is in the on position is the check engine light illuminated? Can you bring up a live data list on the scan tool?
Customer: replied 1 year ago.
I did see a picture there,check engine it is illuminated when starting,and yes I can bring some of the data up,now I just started truck up it ran for like 2or 3 secs the shots off removed spark plugs and pretty flooded with gas
Expert:  Skyvisions replied 1 year ago.
Still no codes?
Customer: replied 1 year ago.
Nope no codes
Expert:  Skyvisions replied 1 year ago.
Did you double check your crankshaft and camshaft position sensor wires to make sure nothing a pinched? If you checked the injector pulse is the injector pulse on your scan tool indicating about 3.4 ms of injection time? If you put a noid light on one of the injectors and started up for the brief moment that it does run for a few seconds is the injector noid light pulsing or is it staying on steady?
Customer: replied 1 year ago.
I found the problem it was the computer
Expert:  Skyvisions replied 1 year ago.
ok

Related Toyota Questions