How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Auto Technician
Category: Toyota
Satisfied Customers: 811
Experience:  16 years of experience
2499435
Type Your Toyota Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

CAMRY: REPLACED MOTOR FROM A 2005 TOYOTA CAMRY (WITH 49K MILES),

Customer Question

REPLACED MOTOR FROM A 2005 TOYOTA CAMRY (WITH 49K MILES), 4CYL (4T1BE32K55U555838). DONOR MOTOR CAME FROM A 2004 TOYOTA CAMRY (VIN: 4T1BE32K64U303093). THE CAR WOULD CRANK BUT WOULD NOT RUN. WITH THE HELP OF STARTER FLUID IT WOULD RUN FOR A FEW SECONDS SO THAT PROVES A GOOD SPARK.
SOMETHING IS PREVENTING FUEL PUMP FROM PUMPING FUEL TO THE INJECTORS.
THE ENGINE WAS REPLACED BECAUSE IT HAD A HAIRLINE CRACK ON THE BLOCK WHERE IT WAS LEAKING OIL. TILL THE MOMENT WE REPLACED THE ENGINE, THE CAR WAS RUNNING PERFECT WITH NO OTHER ISSUES.
WIRE HARNESS FROM THE DONOR ENGINE WAS DIFFERENT THEREFORE WE USED THE HARNESS FROM THE 05 CAMRY.
Submitted: 1 year ago.
Category: Toyota
Expert:  roy replied 1 year ago.
good afternoon my name is ***** ***** I will assist things to checkall fuses. test with a test light to verify power on both sidesground wires. make sure there are no hanging ground wires that need to be attached.can you hear the pump run for 2 seconds with key on?? can you check the pressure?? you can rent a tester at a parts store. Roy
Customer: replied 1 year ago.
All fuses checks out good.
all ground wires in place and none hanging.
pump does not run for 2 seconds.....hence no pressure.Another thing to note is that with the keys out these lights remain turned-on on the cluster: brake light, airbag light, and battery icon light .
Expert:  roy replied 1 year ago.
from your description, it sounds like you have a shorted ignition switch but you did nothing to the switch. check the alternator wiring. remove the wiring and see if it still does it. did you check the fuses for voltage on both sides as I requested?? you said they looked good but you need to verify Roy
Customer: replied 1 year ago.
Both sides of the fuses checked with a test light...all good.There was no such problem prior to replacement of engine (icon lights being on the cluster). Don't know if it is as a result of whatever preventing the fuel pump from pumping?
Expert:  roy replied 1 year ago.
you have a wiring issue somewhere. look around and see if you have any trapped wires or pinched somewhere.
Customer: replied 1 year ago.
That is an obvious answer (not acceptable). I expect a procedure to find out what is causing the fuel pump to not function? Keep in mind that the ECM harness is the same that was working just fine.