How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt, Mechanical Engineer
Category: Toyota
Satisfied Customers: 20396
Experience:  BEng, Repaired my own cars and others for 20 years, worked in Formula 1 for 10 years
Type Your Toyota Question Here...
Matt is online now
A new question is answered every 9 seconds

my toyota super customs van (engine 1 kz) is hard to start...battery

This answer was rated:

my toyota super customs van (engine 1 kz) is hard to start...battery been replaced,injector still ok,heather plug still ok....still hard to start....any idea what need to do


I'd check that you're getting full power to the glow-plugs, they pull a lot of current so take care when checking but see if the relay is clicking when the ignition is turned on first and also check the fuse if this is OK check to see if the engine earth strap is also OK.

You can test the glow-plugs with a multimeter by measuring the resistance across the plug ( between the power connection and the body) it should be around 4-8ohms if its tending to infinity / open circuit the plug is faulty or by using a clip on current clamp, either on the supply wire to glow plugs or onto engine earth, with glow plug light on you should see 15-20amps for each glow plug fitted, 4 cylinders would be approximately 60-80amps.

Also if its not injecting at all then check the connections to the crankshaft sensor, unplug it and check for corroded contacts and broken wiring, and consider fitting a new sensor - do the same for the cam position sensor

If the EGR valve is stuck open then this too can effect starting so try disconnecting it to see if this helps or changes anything

Could also be an injector leaking fuel back through the overspill pipe, so not getting enough fuel pressure to tell ECU to fire the injectors, this is trickier to find and you’ll need the garage to do a ‘run back’ test to identify which one is the issue

Lastly it’s also worth considering fitting a new fuel filter as if only slightly blocked this can lower fuel supply pressure and choke the main pump, the pump will be more sensitive to this when its cold as diesel thickens considerably with low temperatures.

and it may have developed an air leak on the fuel supply pipe from the tank to the engine. The engine has no separate lift pump and relies on the built in one in the injection pump. If a leak has developed on the fuel suction pipe then air entering the system will air lock the pump.
Try pumping up the fuel using the hand pump in the engine bay on the filter housing, then crack off / loosen each injector pipe in turn while cranking the engine and getting an assistant to operate the primer. This will expel air from the injection side and the engine should fire up. The problem will be cured by checking the supply pipe along its length for signs of leakage and repairing any you find.

If you daub each pipe joint with heavy grease and the issue goes away then wipe the grease away one at a time to highlight the problem joint

Customer: replied 3 years ago.

do you have idea where can i buy a new sensor for the crank and cam


try this firm

Matt and other Toyota Specialists are ready to help you

Related Toyota Questions