How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask RIP Your Own Question
RIP
RIP, LEAD TECHNICIAN
Category: Toyota
Satisfied Customers: 5591
Experience:  A.S.E. MASTER TECHNICIAN. TOYOTA SERVICE TRAINING, ADVANCED LEVEL ENGINE PERFORMANCE,CA SMOG, HYBRID
1100518
Type Your Toyota Question Here...
RIP is online now
A new question is answered every 9 seconds

1987 Toyota: 22re..fuel to all the injectors but no..Whats wrong

Customer Question

I have a 1987 Toyota 22re p/u. I have fuel to all the injectors but no further. Whats wrong???
Submitted: 8 years ago.
Category: Toyota
Expert:  RIP replied 8 years ago.

Hi, welcome to JA,

  • If you have 12 volts on the injector connector with the key on, but no trigger to the injector...you may have a bad engine computer...or the computer is not receiving power. Commonly the EFI relay is at fault...have you tested or replaced this relay yet?

Rip

Customer: replied 8 years ago.
Reply to RIP's Post: i have a 1987 toyota 4 runner where is the efi relay?
Expert:  RIP replied 8 years ago.

The EFI or MAIN relay is behind the driver's kick panel in the cab...see the illustrations below.

graphic

graphic

Customer: replied 8 years ago.
YES I ALL READY REPLACED THAT STILL I HAVE NOTHING. IF I SPRAY EATHER IN THE INTAKE IT FIRES RITE UP BUT DOES'T STAY RUNNING IT JUST DIED GOING DOWN THE ROAD SO ITS GOT TO BE SOMTHING SOMEBODYS HAD A PROBLEM WITH ALL READY. THIS IS MY EVERY DAY TRUCK I REALY NEED IT
Expert:  RIP replied 8 years ago.

Well it's definitly something that's happed to other 22RE engine's, but it can be one in a list of problems. You see, by spraying ether in there and the engine runs means it is definitly not getting fuel. We now know it's not the fuel pump becuase you replaced it, and if you got 12 volts to the fuel injector connector that means the fuse is good...so the problem must lye in the computer, or power to the fuel pump, or pressure from the fuel pump. Do you have a pressure guage to test fuel pressure? If there is no pressure you need to test for 12 volts at the pump while cranking the engine. No voltage to the pump means a bad COP (Circuit Opening Relay)...which powers the fuel pump. If the fuel pressure is good, tand all else has checked good you need to verify the injector puse with a Noid Lamp (found at most auto tool stores), if no injector pulse the computer is bad (also shown in the illustration below)

Rip

Customer: replied 8 years ago.
I've checked all that. It all works. Is there another relay on the back drivers side of the truck near the panel (by the back seats)? I think whatever that is, it is the problem... and it looks like what the efi relay looks like when I looked it up for buying a new one. The numbers seem to match too.
Expert:  RIP replied 8 years ago.

Not in the back of the truck...and if you checked all that i've stated above the truck would be running. Let me opt out of this question so other Toyota experts can take a look and see if they can help. Thanks,

Rip

Related Toyota Questions