How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chad Farhat Your Own Question
Chad Farhat
Chad Farhat, ASE Certified Technician A6 - Electrical / Electronic systems A7 Heating / Air conditioning systems
Category: Subaru
Satisfied Customers: 3033
Experience:  Owner at Carolina Auto Service & Sales , 20 years experience in Foreign & Domestic vehicles
45790705
Type Your Subaru Question Here...
Chad Farhat is online now
A new question is answered every 9 seconds

Was driving then the accelerator stopped working in pulled

Customer Question

Was driving then the accelerator stopped working in pulled over to the side and myou car won't start, I have the hazard lights on and the security light is blinking
JA: Does the light flash, blink or stay solid? Have you tried to reset the security system?
Customer: Blink
JA: What is the model/year of your Subaru?
Customer: 2006 legacy
JA: Are you fixing your Legacy yourself? What have you tried so far?
Customer: Nothing yet just letting it sit and then trying to start it
JA: Anything else you want the mechanic to know before I connect you?
Customer: No
Submitted: 4 months ago.
Category: Subaru
Expert:  Chad Farhat replied 4 months ago.

Hi, I'm Chad. Welcome to JustAnswer. I'm reviewing your question and I will be posting your reply ASAP.

Customer: replied 4 months ago.
Lights on dashboard include: awd, at oil temp, oil symbol, battery, check engine, and brake
Expert:  Chad Farhat replied 4 months ago.

Hey how are you

1- the blinking means the anti theft alarm is triggered on .

2- battery needs checked for 12 volts

3- alternator checked for charging 14 volts, did the battery light come on display before it died ?

4- what is the mileage on it ?

5- do you have 1 or 2 keys for it .?

6- did you have any tools on you to disconnect a battery and do a master reset ?

Please let me know

Thank You

Chad Farhat

ASE Certified Technician

Customer: replied 4 months ago.
Tried to master reset, it has 180000 miles on it. I have no way of checking voltage on battery and I have 1 set of keys
Expert:  Chad Farhat replied 4 months ago.

for the car to die like this while driving , you lost either battery or alternator not charging it .

if battery is good , then we lost either fuel or spark ,we need both to stay running?

my experience the CKP crank shaft position sensor fails and car will die while driving ?but testing is needed

when you turn switch from off to ON position not start,do you hear the fuel pump buzzing ?

Please let me know

Thank You

Chad Farhat

ASE Certified Technician

Customer: replied 4 months ago.
I do hear the buzzing when I go from off to on, not sure if fuel pump it's coming from passenger side
Customer: replied 4 months ago.
I do hear a buzzing not sure if fuel pump
Expert:  Chad Farhat replied 4 months ago.

open driver door and try to listen again if you have not

if you don't hear pump could be pump or fuel pump relay?

I sent you location of fuel pump relay

click on link to view diagram location

Please let me know

Thank You

Chad Farhat

ASE Certified Technician

Customer: replied 4 months ago.
Sound came from where fuel pump really is located
Expert:  Chad Farhat replied 4 months ago.

in the fuel tank toward the rear of the car kind under rear seat ,unless it is a wagon

bu look at fuel cap from outside and it will be in line with it under the car

Expert:  Chad Farhat replied 4 months ago.

if fuel pump is running , then you missing spark

Customer: replied 4 months ago.
It is a wagon, and it may be bad alternator? That would explain why the battery wasn't charging?
Expert:  Chad Farhat replied 4 months ago.

yes ,these are good car , i have changed fuel pumps on them but rare or on high mileage one and usual customer runs it low on gas often and suck debris to fail

most common ckp sensor for no spark , it will be hard to start or dies while driving

and battery or alternators ,but usually the light will come on ,but that explains dying on you while running .

Please let me know if you need anything else on it, just reply back and we will continue

If you are good, Please Kindly Rate Me.

A 5 Star Rating is much Appreciated

If you feel I have not been helpful Please DO NOT RATE ME BAD OR POOR (1 or 2 stars) ,You can always ask me again or I can opt out of your question & open it for another expert ,that will provide you with more or better assistance on this issue

Please keep in mind that when you rate me , it does not end our conversation.

you can always come back to this conversation and ask me any follow up question you may have on this issue

(you can copy this link page & paste it in your browser when ready and it will open up our conversation again)

Thank You
Chad Farhat
ASE Certified Technician