How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kevin C. Your Own Question
Kevin C.
Kevin C., Subaru Master Tech.
Category: Subaru
Satisfied Customers: 1727
Experience:  34 years of Subaru service experience, ASE Master Technician.
49406277
Type Your Subaru Question Here...
Kevin C. is online now
A new question is answered every 9 seconds

Have 2007 Subaru Tribeca with h6, engine code reads missing

Customer Question

have 2007 Subaru Tribeca with h6, engine code reads missing on cylinder 1,3, and 5. Change plugs, wires are good, cleaned mass airflow senor and air filter. Did back flow test on exhaust, less than 1. Could this be engine slug or something else?
Submitted: 1 month ago.
Category: Subaru
Expert:  Chad Farhat replied 1 month ago.

Hi, I'm Chad. Welcome to JustAnswer. I'm reviewing your question and I will be posting your reply ASAP.

Expert:  Chad Farhat replied 1 month ago.

hey how are you

1- 1,3 & 5 are on same bank

2- have you check for intake vacuum leaks ?spray starting fluid on that bank on cold engine ,does the engine idle go up ?

3- are the injectors pulsing on that bank?

4- do you have a scanner to tell me fuel trim reading at idle , long term & short term after it warms up at operating temperature ?

5- did you do a wiggle test on the wiring harness on that bank on the injectors, if u move the harness while car running does the skip goes away ?

6-have you removed any ground wires from that side ?

Please let me know

Thank You

Chad Farhat

ASE Certified Technician

Related Subaru Questions