How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190
peterpete190, Auto Technician
Category: Subaru
Satisfied Customers: 24656
Experience:  Auto repair Technician with 17 years experience.Past ASE and other certifications.
14928985
Type Your Subaru Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

Cannot match factory fob to stock (alpine). system does not

Customer Question

cannot match factory fob to stock (alpine). system does not allow to go in to reprogram remote mode. also throws p1507 and p507. idle is high at 2500, then drops and hunts between(###) ###-####
JA: Have you checked the fob's battery?
Customer: yesp, cleaned contacts and replaced battery
JA: What is the model of your '500 Subaru?
Customer: 99 leg wag ob
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: disconnecting battery, deactivate valet mode, in regards ***** ***** alarm. in regards ***** ***** and 0507, checked hoses and connections have not checked IAC valve, was just replaced 5000 miles ago
JA: Anything else you think the mechanic should know?
Customer: replaced burned out alternator 800 miles previous
Submitted: 3 months ago.
Category: Subaru
Expert:  peterpete190 replied 3 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

it sounds like there is a couple of different issues here.First with the fob,if this is only occuring with one fob itself this can be the fob itself at fault needing replaced.I have seen the fob fail in the past before.

With the issue with the idle hunting and idle motor code here this may be a fault with carbon build up in the throttle body needing cleaned or a vacuum leak from something like the intake gaskets leaking needing replaced.I would have the engine checked for any vacuum leaks and if any are found they will need repaired.If this is or was checked and found o.k. the intake should be smoke tested to locate any hard to see leaks like the intake gaskets leaking.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Related Subaru Questions