How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kevin C. Your Own Question
Kevin C.
Kevin C., Subaru Master Tech.
Category: Subaru
Satisfied Customers: 1727
Experience:  34 years of Subaru service experience, ASE Master Technician.
49406277
Type Your Subaru Question Here...
Kevin C. is online now
A new question is answered every 9 seconds

All dash warning light came on one day on the way home from

Customer Question

All dash warning light came on one day on the way home from work. Pulled over and couldn't clear the warnings, but drove the car another 20 miles home. Since then have had problems starting the car and keeping it running. Dealer says the CVT transmission is the problem. Error codes say everything is bad, engine, fuel system, tranny. Car was running fine until got the lights and now it will not start. I think it's the computer and not any of the mechanical parts.
JA: Have you checked the fuses? The dashboard bulbs?
Customer: Fuses, yes, at first. Not the bulbs. Had a Suby some years back that had a starting problem and turned out to be a blown horn fuse . ANy quirks like that wityh this model
JA: What is the model/year of your Subaru?
Customer: 2010 Legacy
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: Understand that the computer has to be programmed by a dealer. True?
JA: Anything else you think the mechanic should know?
Customer: No
Submitted: 9 months ago.
Category: Subaru
Expert:  john -aka eauto replied 9 months ago.

what are the codes?

Customer: replied 9 months ago.
I did not read them, but the local mechanic did and they pointed to engine issues. A Subaru dealer read them and said the tranny was the problem and quotes $7000 to fix it.
Customer: replied 9 months ago.
Car was running fine until the incident with the warning lights ALL coming on.
Expert:  john -aka eauto replied 9 months ago.

does it turn over or is the battery weak or dead?

Customer: replied 9 months ago.
Sorry, but the car is unavailable here as it is my daughter's and at her house some 45 minutes away. I just find it incredible that a car that was running good in a momentary lapse lost all it's major components. To me, everything points to the computer as the source.
Expert:  john -aka eauto replied 9 months ago.

has the dealer looked at it? or was this diagnosed over the phone?

Customer: replied 9 months ago.
Car turns over, does not start though. Car was driven to a Suby dealer who diagnosed the problem after reading the codes. Later the codes were read by a local mechanic who said that they pointed to numerous engine problems.
Expert:  john -aka eauto replied 9 months ago.

do we know the codes? these engines rarely fail

Customer: replied 9 months ago.
I might be able to get them tomorrow. I don't know for sure though. My daughter wants to scrap the car for parts, but it was running so well I hate to see her just junk it. My electronics trouble-shooting experience tells me that the computer is where to start with this problem, but I am not that knowledgeable in these systems.
Expert:  john -aka eauto replied 9 months ago.

computers rarely fail...get me the codes we can try to sort it out

Customer: replied 9 months ago.
I will have to call her husband tomorrow to check if he has anything written down on the codes. It's been over a month now that it has been sitting in their driveway so he may not have anything.
Expert:  john -aka eauto replied 9 months ago.

what state is the car in was it subaru that diagnosed

Customer: replied 9 months ago.
New York
Expert:  john -aka eauto replied 9 months ago.

greetings from utica Ny....

Customer: replied 9 months ago.
We're down in the Catskills.
Expert:  john -aka eauto replied 9 months ago.

how many miles on it...?

Customer: replied 9 months ago.
160K
Expert:  john -aka eauto replied 9 months ago.

if you can accept the phone request we can try and sort it out...what subaru dealer did it go to out of curiosity

Customer: replied 9 months ago.
I have not problem using the phone, just don't have any more information or even the auto available for reference. Believe it was diagnosed by Ruge's Subaru dealership in Kingston. Her husband did tell me that before he brought it to Ruge's that he and a friend did reboot the computer. They had read the codes using a unit his friend had. Why they rebooted I can't say.
Expert:  john -aka eauto replied 9 months ago.

does it run and drive currently? does it do anything abnormal other then the lights?

Customer: replied 9 months ago.
They were able to drive it to the local mechanic after taking it 100+ miles round trip to Kingston and back, but claim that it will not start now. They did managed to drive it home from the local mechanic's shop about a week ago.Car was running just fine until the dash light up one evening when my daughter was driving home from work. I drove the car myself and it ran great! I can't believe everything went down the tubes just like that with no fore-warning whatsoever.
Expert:  john -aka eauto replied 9 months ago.

does it just crank and not start? or no power?

Customer: replied 9 months ago.
Car cranks OK, just doesn't always want to start to stay running once it does. Read where some owners had stalling issues with this year/model.
Expert:  john -aka eauto replied 9 months ago.

just so rare for a non turbo subaru motor to fail..love to here what codes they found and how they determined the motor failed

Customer: replied 9 months ago.
The original diag was bad tranny (Ruge's quoted $7000 fix), local mechanic said codes he got pointed to that and the engine also as the source. I just find it hard to swallow that this perfectly good running car came "apart" virtually overnight! Just does not make sense. I'm on my 3rd Suby now and got over 200 and 250K on my last two!
Expert:  john -aka eauto replied 9 months ago.

mine has 225 and runs like new

Expert:  john -aka eauto replied 9 months ago.

well try and get me the codes...we can try and sort it out...or send it to utica ;)

Customer: replied 9 months ago.
The one I had before out current 2004 was a 1992 Legacy and it had over 250K and was running when I got ride of it. I tried calling them, but they must be in bed. I will get what info they have tomorrow. How do I get in touch with you?
Expert:  john -aka eauto replied 9 months ago.

ill be on and off all day tomorrow i log on between cars or lulls in work and im on every night so just respond like you have been and when i see it ill respond

Customer: replied 9 months ago.
OK. I'll get whatever info they have. Thanks and have a good night.
Expert:  john -aka eauto replied 9 months ago.

same to you