How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190
peterpete190, Auto Technician
Category: Subaru
Satisfied Customers: 26651
Experience:  Auto repair Technician with 17 years experience.Past ASE and other certifications.
14928985
Type Your Subaru Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

My husband and I just replaced the clutch, timing belt,

Customer Question

Hi!
JA: Hi. What seems to be the problem?
Customer: My husband and I just replaced the clutch, timing belt, water pump and gaskets on my 04 Subaru forester
JA: So many things can cause water pump issues. Some simple, some complicated. Fortunately, the mechanics we work with have tons of experience dealing with them. Tell me a bit more about what's going on so he can help you best.
Customer: but now, my high beams won't turn off
JA: Are you hoping to fix this yourself?
Customer: and he rolled down the windows and they won't roll back up
JA: Is there anything else important you think the Subaru Mechanic should know about your Subaru?
Customer: any ideas?
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Subaru Mechanic about your situation and then connect you two.
Customer: I am assuming a fualty ground wire, but...
Submitted: 10 months ago.
Category: Subaru
Expert:  peterpete190 replied 10 months ago.

Hi,my name is ***** ***** I will be happy to try to assist you with this.I may need more information in some cases to help with answering your question.

Expert:  peterpete190 replied 10 months ago.

Check for any loose or disconnected grounds or wiring that was removed when the clutch and other engine repairs were done.In most all cases after a repair like this has been done I have found that this issue here can be caused by loose or damaged wiring or connections in the engine bay area or where the transmission bolts up to the engine.I would trace the engine bay and transmission harness to see if any issues are found needing repaired or replaced to correct this fault here.If this is checked and found to be o.k. let me know so we can continue.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete