How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask tamaz Your Own Question
tamaz, Subaru master technician
Category: Subaru
Satisfied Customers: 1117
Experience:  Subaru certified,ASE Master technician,25 years experience
Type Your Subaru Question Here...
tamaz is online now
A new question is answered every 9 seconds

I have a shakey under powered engine. It was fine the today

Customer Question

I have a shakey under powered engine. It was fine the today spontaneously I had a poer loss and a studder. The intial codes were p0301 and p0303. I pulled the plug wires cyl 1 stalled the engine cyl 3 no change dead cylinder. I pulled the plugs both were sooted black build up. I thought plug tube gaskets nope. Now after driving again codes are same as above plus p0304 and ecm p0604. Any thoughts
JA: The mechanics have tons of experience in that area. Are those all of the "symptoms"?
Customer: Yea for now I have no problem with fixing stuff myself I just dont want to throw money at it. I would like to narrow it down.
JA: Anything else I can tell the Subaru Mechanic before I connect you two?
Customer: Yea
JA: What else should I tell the Subaru Mechanic?
Customer: No sorry that is it
JA: Got it. Let's get this figured out. I'm sending you to a secure page on JustAnswer so you can place the $5 fully refundable deposit now. While you're filling out that form, I'll tell the Subaru Mechanic about your situation and connect you two. You'll be on the road in no time.
Submitted: 6 months ago.
Category: Subaru
Expert:  tamaz replied 6 months ago.
Hi,just a few preliminary questions here,what year and model Subaru is this,were the plugs and ignition wires replaced,thanks
Customer: replied 6 months ago.
04 outback, yes not but 6 months ago. My 2nd cyl and 4th cyl plugs are clean. From the dry soot on both 1 and 3 I am now suspecting fuel injectors. I think the p0304 and po604 were a fluke from driving home on it. Your thoughts.
Expert:  tamaz replied 6 months ago.
If it's somewhat intermittent I would suspect possibly the ignition coil,try the wet test,while the engine is running spray the coil and ignition wires with water,if you see any arcing or the engine idling poorly you have found a fault in one or more of these components.
Customer: replied 6 months ago.
I will when it gets dark, but when I pulled the ignition wires they were arcing like mad. I pulled them both at spark plug boot and connection to the coil. I have the injectors soaking in 91% ipa. I have not done a compression test yet. How are these boxer engines headgaskets set up? Are they split or one whole gasket?
Expert:  mike switzer replied 6 months ago.
they are one gasket for each head. so one gasket for each cylinder. these engines have notorious coil issues when warm i would go with tamaz's suggestion.
Customer: replied 6 months ago.
The problem I have is it is the issue is present during warm up. It is their at ignition and warmed up.
Expert:  mike switzer replied 6 months ago.
it may still be the coil. typically they have this issue when warm but if severe it will become all the time. and once it arcs through it has now found and easier route and made it easier to flow through with every arc.
Customer: replied 6 months ago.
I will check it out and gove you an update. I hope it is a coil. Kow
Expert:  tamaz replied 6 months ago.
I'll be here ,thanks
Customer: replied 6 months ago.
Ok not the coil took plug out and it is arching. new devlopments I am pretty sure it is only cyl 3 that is the problem. I soaked the injectors all night. When I put them in no change. I checked the volts to their connectors 1 has amperage 3 has none. Should I get a new connctor and splice it in or ?.
Customer: replied 6 months ago.
Oh yea I am about to do a compression test.
Customer: replied 6 months ago.
Ok might have to do the volt meter again. Compression test 0 on cyl 3 all the others are fine. I poured oil into 3 and nothing. So is that more likley a valve issue?
Expert:  tamaz replied 6 months ago.
Hi ,zero on 3 most likely a valve issue we've had problems with exhaust valve guides loosening and dropping causing valves to hang open you can usually see this if you drop the exhaust at the cylinder heads and take a look up into the exhaust
Customer: replied 6 months ago.
So the downpipe is what your refering to? Then what am I looking for?
Expert:  tamaz replied 6 months ago.
Yes, once it is lowered you can see all exhaust valves and guides,if the guides have loosened you can clearly see how far the guide has moved
Customer: replied 6 months ago.
Well it will be a week or so until you hear from me. The studs and nuts are rusted solid one came out and brought threads with it. I am going to have to soak them with penetrating oil. I am an otr truck driver and am out Monday through Friday. I will get back to you on it. Thanks Jeff
Expert:  tamaz replied 6 months ago.
Jeff, no problem,safe travels I'll talk to you soon.