How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask FIXITMAN Your Own Question
FIXITMAN
FIXITMAN, Master Technician
Category: Subaru
Satisfied Customers: 17143
Experience:  ASE MASTER CERTIFIED, AA DEGREE AUTO/DIESEL TECH
1627031
Type Your Subaru Question Here...
FIXITMAN is online now
A new question is answered every 9 seconds

I'm getting code 0028 on my 2006 Outback H6. Already checked

Customer Question

I'm getting code 0028 on my 2006 Outback H6. Already checked connections and replaced oil pressure sender...Throw code after 10 miles or so
JA: Tell me a bit more about what's going on so he can help you best.
Customer: just did
JA: Are you hoping to fix this yourself?
Customer: of cpurse
JA: Is there anything else the Subaru Mechanic should be aware of about your Subaru?
Customer: just bought the car
JA: Our top Subaru Mechanic is ready to take your case. Just pay the $5 fully refundable deposit and I'll fill the Subaru Mechanic in on everything we've discussed. You can go back and forth with the Subaru Mechanic until you're 100% satisfied. We guarantee it.
Submitted: 8 months ago.
Category: Subaru
Expert:  FIXITMAN replied 8 months ago.

Hello, my name is***** you for the question. Can you tell me how the vehicle is actually driving besides the light being on?

Customer: replied 8 months ago.
It drives just fine. The Avcs works flawlessly for 10 min or so until it throws the code. Lots of power. Shifts well. The oil was just changed and I removed the left bank solenoid to look at it...seems clean and moves normally. Didn't clean it tho.
Customer: replied 8 months ago.
Just cleaned with carbon tet and tested with 12v test leads. Retracts full stroke and passages are clean and unobstructed
Expert:  FIXITMAN replied 8 months ago.
Thanks. Does your scan tool read the data from the position sensor?
Customer: replied 8 months ago.
No
Expert:  FIXITMAN replied 8 months ago.

Thank you. It sounds like it needs the solenoid itself. These are a very common issue on this engine.

Customer: replied 8 months ago.
Weird stuff now. Cold startup produces a momentary rattle then it runs fine for a few minutes until fast idle comes down...which throws #2 misfire code 0302 with flashing CEL. Last startup produced same roughness, same flashing CEL but with the 0018 code. WTF?
Expert:  FIXITMAN replied 8 months ago.

Have you ever has the timing chain replaced on this engine?

Customer: replied 8 months ago.
No. I just bought the car. These H6s typically go 4 to 500k Kilometers before any major service is needed. Maybe I should pull the cover and have a look?
Expert:  FIXITMAN replied 8 months ago.

I would. You may have a worn timing chain or a bad tensioner. That will also cause the rattle.

Customer: replied 8 months ago.
Installed new chain tensioners...chain and guides excellent, no wear. No more rattle but still throws 0018 code, runs rough after warmup. Initially threw 2,4 and 6 misfire codes. Could this be a bad Crank or Cam position sensor?
Customer: replied 8 months ago.
This is BS! Why won't you respond? This problem is not solved yet!

Related Subaru Questions