How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Subaru
Satisfied Customers: 21602
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
9825021
Type Your Subaru Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

I bought a 2008 subaru wrx at an auction. It a print mount

Customer Question

I bought a 2008 subaru wrx at an auction. It a print mount intercooler. Blow off valve. The car ran perfect. All monitors were ready. No codes. After about 40 miles a code came on for bank one too rich. I reset the monitors while it was running. Started it up the next day and the idle is all over the place. Stalling.
Submitted: 9 months ago.
Category: Subaru
Expert:  sprinkles08 replied 8 months ago.

Hello and welcome to JustAnswer!

There are a handful of things that will cause a fuel system rich code to set or the driveability problem. If there are more modifications that listed here or you're aware of that may be a factor.

An inaccurate upstream oxygen sensor is a likely cause for the code and could also cause the engine to run incorrectly rich or lean. Does the engine run normally when initially started but then starts to run poorly?

Customer: replied 8 months ago.
The question was not addressed. He addressed a completely different question I did not ask him. I would like a refund. Completely useless
Expert:  sprinkles08 replied 8 months ago.

I addressed the question posted to this page. This is the question text posted here:

I bought a 2008 subaru wrx at an auction. It a print mount intercooler. Blow off valve. The car ran perfect. All monitors were ready. No codes. After about 40 miles a code came on for bank one too rich. I reset the monitors while it was running. Started it up the next day and the idle is all over the place. Stalling.